UVa 101 - The Blocks Problem(STL)


 The Blocks Problem 

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AIstudy of planning and robotics (STRIPS) used a block world in which arobot arm performed tasks involving the manipulation of blocks.

In thisproblem you will model a simple block world under certain rules andconstraints. Rather than determine how to achieve a specified state,you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot armin how to manipulate blocks that lie on a flat table. Initially thereare n blocks on the table (numbered from 0 to n-1)with block b i adjacent to block b i+1for all $0 \leq i < n-1$as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure:Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto blockb afterreturning any blocks that are stacked on top of blocksa andb totheir initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of thestack containing blockb, after returning any blocks that are stackedon top of blocka to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consistingof blocka, and any blocks that are stacked above blocka, ontoblock b. All blocks on top of block b are moved to their initialpositions prior to the pile taking place. The blocks stacked above blocka retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consistingof blocka, and any blocks that are stacked above blocka, ontothe top of the stack containing blockb. The blocks stacked above blocka retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and bare in the same stack of blocks is an illegal command. All illegalcommands should be ignored and should have noaffect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representingthe number of blocks in the block world. You may assume that 0 < n <25.

The number of blocks is followed by a sequence of block commands, onecommand per line. Yourprogram should process all commands until thequit command isencountered.

You may assume that all commands will be of the form specified above.There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Eachoriginal block position numberedi ($0 \leq i < n$wheren is the number of blocks) should appearfollowed immediately by a colon.If there is at least a blockon it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position(i.e., n lines of output wheren is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:


代码如下:(错误还未纠正)

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
using namespace std;
const int maxn = 30;
int n;//木块数
vector<int> pile[maxn];//每个pile[i]是1个vector
//相当于定义了maxn个vector“数组”,就等价于一个二维数组
void find_block(int a,int &p,int &h);
void clear_above(int p,int h);
void pile_onto(int p,int h,int p2);
int main()
{
    int x,y;
    string str,doing;//操作名称move or quit , onto or over
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        pile[i].push_back(i);
    while(cin>>str>>x>>doing>>y)
    {
        //if(str=="quit")
            //break;
        //cin;
        int pa,pb,ha,hb;//分别是a和b的所在行,所在列
        //当pile[i]当二维数组来用
        //扫描一下当前a的行列位置
        find_block(x,pa,ha);
        find_block(y,pb,hb);


        if(pa == pb) continue;//如果将x==y,不用考虑
        if(doing=="onto") clear_above(pb,hb);//将第pb堆上高度大于h的木块归位
        if(str=="move")   clear_above(pa,ha);
        pile_onto(pa,ha,pb);//移动
    }

    //输出
    for(int i=0;i<n;i++)
    {
        printf("%d:",i);
        for(int j=0;j<pile[i].size();j++)
            printf(" %d",pile[i][j]);
        printf("\n");
    }
    return 0;
}


void find_block(int a,int &p,int &h)//找出a和b的所在行,所在列
{
    for(p=0;p<n;p++)
        for(h=0;h<pile[p].size();h++)
            if(pile[p][h]==a)   return;
}


void clear_above(int p,int h)//将第p堆高度超过h的木块移回原位
{
    for(int i=h+1;i<pile[p].size();i++)
    {
        int b=pile[p][i];
        pile[b].push_back(b);
    }
    pile[p].resize(h+1);//pile应该保留下标0~h的元素
}


void pile_onto(int p,int h,int p2)//将第p堆高度超过h的木块整体移动到p2的顶部
{
    for(int i=h;i<pile[p].size();i++)
        pile[p].push_back(pile[p][i]);
    pile[p].resize(h);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值