hoj 2603 Look and Say

Look and Say

The look and say sequence is defined as follows. Start with any string ofdigits as the first element in the sequence. Each subsequent element isdefined from the previous one by "verbally" describing the previouselement. For example, the string 122344111 can be described as "one 1,two 2's, one 3, two 4's, three 1's". Therefore, the element that comesafter 122344111 in the sequence is 1122132431. Similarly, the string101 comes after 1111111111. Notice that it is generally not possible touniquely identify the previous element of a particular element. Forexample, a string of 112213243 1's also yields 1122132431 as the nextelement.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input

3
122344111
1111111111
12345

Sample Output

1122132431
101
1112131415
很简单直接贴代码:

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1000+2
char Str[N];
char str[N * 3] = { 0 };
void Look_and_Say(char *S)
{
	int i, j, k, p, count;
	int len = strlen(S);
	k = 0;
	for (i = 0; i < len; i++)
	{
		count = 0;
		for (j = i; j < len; j++)
		{
			if (S[i] == S[j])
			{
				count++;
			}
			else
			{
				if (count>1)
					i += count - 1;
				break;
			}
		}
		if (count >= 10)
		{
			char temp[10] = { 0 };
			sprintf(temp, "%d", count);
			for (p = 0; p < strlen(temp); p++)
			{
				str[k++] = temp[p];
			}
			str[k++] = S[i];
		}
		else
		{
			str[k++] = count + '0';
			str[k++] = S[i];
		}
		if (j == len)
		{
			i = len;
		}
	}
	str[k] = '\0';
	printf("%s\n", str);
}

int main()
{
	int m;
	scanf("%d\n", &m);
	while (m--)
	{
		gets(Str);
		Look_and_Say(Str);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值