hoj 1066 Substrings

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
Input
The first line of the input file contains a single integer t (1<=t<=10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1<=n<=100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
Output
There should be one line per test case containing the length of the largest string found.
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2 

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MaxSize 105
char input[MaxSize][MaxSize];
int cmp(const void *a, const void *b)
{
	if (strlen((char *)a) == strlen((char *)b))
		return 0;
	else
		return ((strlen((char *)a) > strlen((char *)b))) ? 1 : -1;
}
void ReversealStr(char *str)
{
	int i, j = strlen(str) - 1;
	for (i = 0; i < j; i++, j--)
	{
		str[i] = str[i] ^ str[j];
		str[j] = str[i] ^ str[j];
		str[i] = str[i] ^ str[j];
	}
}
void CreateSubStr(char *S1, char *S2, int n1, int n2)
{
	int i, k = 0;
	for (i = n1; i <= n2; i++)
	{
		S2[k++] = S1[i];
	}
	S2[k] = '\0';
}
int main()
{
	int i,j,p,n,m,Max;
	scanf("%d", &m);
	while (m--)
	{
		Max = 0;
		memset(input, 0, sizeof(input));
		scanf("%d", &n);
		for (i = 0; i < n; i++)
			scanf("%s", input[i]);
		qsort(input, n, sizeof(input[0]), cmp);
		char s1[MaxSize];
		char s2[MaxSize];
		int len = strlen(input[0]);
		for (i = len - 1; i >= 0; i--)
		{
			memset(s1, 0, sizeof(s1));
			memset(s2, 0, sizeof(s2));
			int k = 0;
			for (j = i; j < len; j++)
			{
				CreateSubStr(input[0], s1, k, j);
				strcpy(s2, s1);
				ReversealStr(s2);
				for (p = 0; p < n; p++)
				{
					if (!strstr(input[p], s1) && !strstr(input[p], s2))
						break;
				}
				if (p == n && strlen(s1)>Max)
					Max = strlen(s1);
				k++;
			}
		}
		printf("%d\n", Max);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值