UVa673(括号匹配)

Description

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)if it is the empty string(b)if A and B are correct, AB is correct,(c)if A is correct, () and  [] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses ()and [], one string a line.

Output

A sequence of Yes or No on the output file.

Sample Input

?
1
2
3
4
3
([])
(([()])))
([()[]()])()

Sample Output

?
1
2
3
Yes
No
Yes

#include<iostream>
#include<string>
#include<stack>
using namespace std;
int main()
{
    int n;
    cin>>n;
    cin.get();
    while(n--)
    {
        stack<char> s;
        string str;
        int flag=0;
        getline(cin,str);
        for(int i=0;i<str.size();i++)
        {
            if(str[i]=='['||str[i]=='(') s.push(str[i]);
            else if(!s.empty()&&s.top()=='('&&str[i]==')') s.pop();
            else if(!s.empty()&&s.top()=='['&&str[i]==']') s.pop();
            else flag=1;
        }
        if(!flag&&!s.size()) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
     }
     return 0;
}



  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值