UVa 673 - Parentheses Balance


  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  (A ) and  [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n  and a sequence of  n  strings of parentheses  ()  and  [] , one string a line.

Output 

A sequence of  Yes  or  No  on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes



Miguel Revilla 
2000-08-14
栈的应用 :注意此题有空行的时候这种情况输出Yes
#include <stdio.h>
#include <string.h>
#include <math.h>
char s1[1000];
char sta[10000];
int main()
{
    int i,j,n,m,s,t;
    int l,top1,top2;
    scanf("%d%*c",&n);
    while(n--)
    {
        gets(s1);
        l=strlen(s1);
        if(l==0)
        {
            printf("Yes\n");
            continue;
        }
        top1=top2=0;
        if(s1[0]==')'||s1[0]==']')
        {
            printf("No\n");
            continue;
        }
        sta[top2++]=s1[0];
        for(i=1;i<=l-1;i++)
        {
            if(s1[i]=='('||s1[i]=='[')
            {
                sta[top2++]=s1[i];
            }else
            {
                if(top2==0)
                {
                    break;
                }
                if(s1[i]==')')
                {
                    if(sta[top2-1]=='(')
                    {
                        top2-=1;
                    }else
                    {
                        break;
                    }
                }else if(s1[i]==']')
                {
                    if(sta[top2-1]=='[')
                    {
                        top2-=1;
                    }else
                    {
                        break;
                    }
                }
            }
        }
        if(top2==0&&i==l)
        {
            printf("Yes\n");
        }else
        {
            printf("No\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值