PAT (Advanced Level) Practise 1021. Deepest Root (25)

22 篇文章 0 订阅
10 篇文章 0 订阅

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:

Error: 2 components

代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=10010;
vector<int> G[maxn];
int tree[maxn];

int findRoot(int x){
    if(tree[x]==-1) return x;
    else{
        int tmp=findRoot(tree[x]);
        tree[x]=tmp;
        return tmp;
    }
}

int maxh=0;
vector<int> temp,ans;

void dfs(int u,int h,int pre){
    if(h>maxh){
        temp.clear();
        temp.push_back(u);
        maxh=h;
    }
    else if(h==maxh) temp.push_back(u);
    for(int i=0;i<G[u].size();i++){
        if(G[u][i]==pre) continue;
        dfs(G[u][i],h+1,u);
    }
}

int main(){
    int n,a,b;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) tree[i]=-1;
    for(int i=1;i<n;i++){
        scanf("%d%d",&a,&b);
        G[a].push_back(b);
        G[b].push_back(a);
        a=findRoot(a);
        b=findRoot(b);
        if(a!=b) tree[a]=b;
    }
    int block=0;
    for(int i=1;i<=n;i++) if(tree[i]==-1) block++;
    if(block!=1) printf("Error: %d components\n",block);
    else{
        dfs(1,1,-1);
        ans=temp;
        dfs(ans[0],1,-1);
        for(int i=0;i<temp.size();i++) ans.push_back(temp[i]);
        sort(ans.begin(),ans.end());
        printf("%d\n",ans[0]);
        for(int i=1;i<ans.size();i++){
            if(ans[i]!=ans[i-1]) printf("%d\n",ans[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值