HDU1856 More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
 
 
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题解:

也是一道简单的并查集模板的题目,主要是利用并查集计算最大连通子图的节点个数,需要设置一个num数组存储连通子图的节点个数。

代码:

#include <cstdio>
#include <cstring>
const int maxn=1e5+10;
int tree[maxn],num[maxn];

int findRoot(int x){
    if(tree[x]==-1) return x;
    else{
        int tmp=findRoot(tree[x]);
        tree[x]=tmp;
        return tmp;
    }
}

int main(){
    int n;
    while(scanf("%d",&n)==1){
        memset(tree,-1,sizeof(tree));
        for(int i=1;i<=100000;i++) num[i]=1;
        for(int i=1;i<=n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            a=findRoot(a);
            b=findRoot(b);
            if(a!=b){
                tree[a]=b;
                num[b]+=num[a];
            }
        }
        int Max=0;
        for(int i=1;i<=100000;i++){
            if(num[i]>Max) Max=num[i];
        }
        printf("%d\n",Max);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值