hdu 1856 more is better

题目

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

样例输出

4
2

提示

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).
In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题目分析

本题为将最大的连通数字个数解出,在大量数据下,可采用并查集的方法进行求解,通过不断搜索根节点,计算各类情况下,相应的最大连通数字。

代码

#include<iostream>
using namespace std;

int *a= new int [10000001];
int *b= new int [10000001];
//初始化
void init()
{
	for(int i = 0;i<=10000000;++i)
	{
		a[i]=i;
		b[i]=1;
	}
}
//寻找根节点
int find(int obj)
{
	if(a[obj]==obj)//找到根节点
		return obj;
	else
	{
		a[obj] = find(a[obj]);//压缩路径
		return a[obj];
	}
}

void merge(int x,int y)
//合并集合,即将两个根节点不同的树,把他们根节点归一
//同时将对应的最大数相加
{
	int p = find(x);
	int q = find(y);
	if(p != q)//根节点不同
	{
		a[p]=q;//取出一个作根节点
		b[q]+=b[p];//最大数相加
	}
}

int main()
{
	int m,x,y,more;
	while(scanf("%d",&m)!=EOF)
	{
		init();
		for(int i = 0;i<m;++i)
		{
			scanf("%d %d",&x,&y);//scanf速度远快于cin
			merge(x,y);
		}
		more = 0;
		for(int i = 1;i<=10000000;++i)//取最大的数
		{
			if(more<b[i])
				more = b[i];
		}
		cout << more<<endl;
	}
	delete a;
	delete b;
	return 0;
}

运算结果

在这里插入图片描述

链接

http://acm.hdu.edu.cn/showproblem.php?pid=1856

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

registor11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值