hdu 1007 Quoit Design 最近点对

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30804    Accepted Submission(s): 8093


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75


给出平面上一些点,求出这些点中最近两点的距离。

最近点对模版直接上~

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

#define maxn 100010
#define inf 0x3f3f3f3f
struct Point{
	double x,y;
};
Point p[maxn],t[maxn]; 
int n;
///
bool cmpx(Point a,Point b){
	return a.x < b.x;
} 
bool cmpy(Point a,Point b) {
	return a.y < b.y;
}
double dis(Point a,Point b){
	return (a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y);
}
double DnC(int L,int R){
	if(L>=R) return inf;
	// divide
	int M = (L+R)>>1;
	double d = min(DnC(L,M),DnC(M+1,R));
	
	//conquer
	int N = 0;
	for(int i=M;i>=L && p[M].x-p[i].x<d ;i--) t[N++] = p[i];
	for(int i=M+1;i<=R && p[i].x-p[M].x<d;i++) t[N++] = p[i];
	sort(t,t+N,cmpy);
	
	for(int i=0;i<N-1;i++){
		for(int j=1;j<=3 && i+j<N;j++){
			d = min(d,dis(t[i],t[i+j]));
		}
	}
	return d;
}
double Closest_pair(){
	sort(p,p+n,cmpx);
	return sqrt(DnC(0,n-1));
}
int main(){
	while(scanf("%d",&n)!=EOF && n){
		for(int i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
		printf("%.2f\n",Closest_pair()/2);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值