poj3252Round Numbers

Description
The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish
Sample Input
2 12
Sample Output

6

题意:输入两个数n,m,求n~m(化为2进制)中0的个数大于等于1的个数的数的个数。

#include<cstdio>
#include<cstring>

int num[1000], note[100][100][100];

int dfs(int now, int len0, int len1, bool flag){
    /**********************************
    if(now == -1)
        if(len0 >= len1) return 1;
        else return 0;
    /************************************/
    //更优美的写法
    if(now == -1) return len0 >= len1 ? 1 : 0;
    /*********************************/
    if(!flag && note[now][len0][len1] != -1) return note[now][len0][len1];
    int ret = 0;
    int limit = flag ? num[now] : 1;//上限
    for(int i = 0; i <= limit; i++){
        int len00 = len0, len11 = len1;
        if(i == 0 && len1) len00 = len0 + 1;//避免0是前导的
        if(i == 1) len11 = len1 + 1;//不用else,因为前导0是要忽略的
        ret += dfs(now - 1, len00, len11, flag && i == limit);//继续考虑上限问题
    }
    if(!flag) note[now][len0][len1] = ret;
    return ret;
}

//转化二进制函数
int work(int x){
    int len = 0;
    while(x){
        num[len++] = x % 2;//num[0]是最低位,num[len - 1]是最高位
        x /= 2;
    }
    return dfs(len - 1, 0, 0, true);
}

int main(){
    int n, m;
    memset(note, -1, sizeof(note));
    while(scanf("%d%d", &n, &m) == 2)
        printf("%d\n", work(m) - work(n - 1));
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值