[poj 3252] Round Numbers 组合数学

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11386 Accepted: 4262

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.

Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

Source
USACO 2006 November Silver

题目链接http://poj.org/problem?id=3252
题意:Round Numbers 就是一个表示成二进制的时候0比1多或者相等的正数给定一个区间,问在这个区间上的Round Numbers有多少个?

思路:把n变二进制数,分两种方式计算:
1.位数小于len的:i —c[i][i/2+1]+…+c[i][i];
2.位数等于的计算0—-x-1的个数(因为第一位为1,而且计算同位时只考虑把1变0,即变小的情况)
*c递推计算
*计算时把首位当作‘1’,算其余!;

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int c[35][35];
int n,m;
int shu[35];
void com()
{

    for(int i=0;i<=33;i++)
    for(int j=0;j<=i;j++)
    {
        if((!j)||(i==j)) c[i][j]=1;
        else 
        c[i][j]=c[i-1][j-1]+c[i-1][j];
    }

    return ;
}
int cal(int n)
{
    int ret=0;
    shu[0]=0;
    while(n)
    {
        shu[++shu[0]]=n%2;
        n/=2;
    }
    for(int i=1;i<=shu[0]-2;i++)
    {
        for(int j=i/2+1;j<=i;j++) 
            {
                ret+=c[i][j];
            }
    }
    int num=0;
    for(int i=shu[0]-1;i>=1;i--)
    {
        if(shu[i]==0) num++;
        else
        {
            for(int j=(shu[0]+1)/2-(num+1);j<=i-1;j++)    // To avoid the differs between the 1th '1' & parity
            ret+=c[i-1][j];
        }
    }
    return ret;

}
int main()
{
    scanf("%d%d",&n,&m);
    com();
    //cout<<cal(3)<<endl;
    printf("%d\n",cal(m+1)-cal(n));   //cal(x)  计算0----x-1的个数(因为第一位为1,而且计算同位时只考虑把1变0,即变小的情况)   
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值