1815. 计算两点间的距离 easy

1815. 计算两点间的距离

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

请用类描述顶点信息,输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

 

Input

输入数据第一行一个整数 n,代表测试数据组数,接下来 n 行,每行由 4 个实数组成,分别表示 x1,y1,x2,y2,数据之间用空格隔开。

 

Output

对于每组测试数据,输出一行,结果保留两位小数。

 

Sample Input

2
0 0 0 1
0 1 1 0

Sample Output

1.00
1.41


#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

int main () {
	int T;
	cin>>T;
	while (T--) {
		double x1, y1, x2, y2;
		cin>>x1>>y1>>x2>>y2;
		double l = sqrt(pow(x1-x2,2)+pow(y1-y2,2));
		printf("%0.2f\n",l);
	}

	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值