2470. Matrix Commutative Multiplication 输入n要用scanf否则会WA别问我为什么我也不知道…

2470. Matrix Commutative Multiplication

Constraints

Time Limit: 5 secs, Memory Limit: 256 MB

Description

Given a square matrix of order N. Your task is to check whether AB=BA for all square matrix of the same order N.

Input

The input begins with the integer t, the number of test cases. Then t test cases follow. 

For each test case:

  • In the first line there is an integer N (N <= 1000)
  • In next N lines, each line contains N integer. All integers don't exceed 1000.
     

Output

For each test case, write "YES" if AB=BA for all square matrix of the same order N, otherwise write "NO".

Sample Input

2
2
1 1
1 2
2
1 0
0 1

Sample Output

NO
YES

Problem Source

yessit



#include <iostream>
#include <stdio.h>

using namespace std;

int main () {
	int T;
	//scanf("%d", &T);
	cin>>T;
	while (T--) {
		int n;
		scanf("%d", &n);
		//cin>>n;
		int fixed;
		bool flag = true;
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				int inter;
				scanf("%d", &inter);
				if (i == 1 && j == 1)  //第一次 记录对角线的值
					fixed = inter;
				if (i == j)   //判断对角线上的值是否相等
					if (inter != fixed)
						flag = false;			
				if (i != j)  //判断其他值是否为0
					if (inter != 0)
						flag = false;
			}	
		}

		if (flag)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;	
	}

	//system("pause");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值