1798.2683. Alice and Bob 看输入(棋盘边)是奇还是偶就可以了

2683. Alice and Bob

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Bob is very famous because he likes to play games. Today he puts a chessboard in the desktop, and plays a game with Alice. The size of the chessboard is n by n. A stone is placed in a corner square. They play alternatively with Alice having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game.If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line. The integers are between 1 and 10000, inclusive, indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner (“Alice” or “Bob”) for each input line except the last zero. No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

Alice

Problem Source

系列热身赛5@2011年上半学期算法考试和4+2选拔赛


#include <iostream>
#include <stdio.h>

using namespace std;

int main () {
	int n;
	while (cin>>n && n) {
		if (n % 2 != 0)
			cout<<"Bob"<<endl;
		else
			cout<<"Alice"<<endl;
	}

	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值