POJ 1860

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16956 Accepted: 5943

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

给你一些钱之间的兑换关系,你现在有一定数量的s货币,问你能不能经过一系列的交换使得你拥有更多的s货币。

已知A货币到B货币的关系是B=(A-C)*R

按题意直接建图,在每条边上维护两个权值C和R,一开始d[s]=vv,vv为开始时的货币数。然后从s出发,对于每一条边<U,V>,我们用V=(U-C)*R求V的权值,最后判是否存在一条从x到x的路径使得第二次到x时获得的权值更大。因为如果存在这样的路径,我们就可以从x到x无限循环获得无限的x,再用无限的x兑换无限的s即可(题目保证了a能到b,b就能到a)。可以用类似spfa判负环的方法去判断但是用dfs判负环会更快,当然本题应该是判断“正环”。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 509
#define maxm 509
#define eps 1e-9
#define INF 999999999
using namespace std;
int n,m,tot,s;
double vv;
int first[maxn],next[maxn],u[maxn],v[maxn];
bool vis[maxn];
double r[maxn],c[maxn],d[maxn];
bool dfs(int cur)
{
    vis[cur]=1;
    for(int e=first[cur];e!=-1;e=next[e])
    {
        if(d[v[e]]<(d[cur]-c[e])*r[e]&&d[cur]>c[e])
        {
            d[v[e]]=(d[cur]-c[e])*r[e];
            if(vis[v[e]])return 1;
            if(dfs(v[e]))return 1;
        }
    }
    vis[cur]=0;
    return 0;
}
bool poscir()
{
    for(int i=1;i<=n;i++)d[i]=0;
    d[s]=vv;
    if(dfs(s))return 1;
    else return 0;
}
void add(int x,int y,double rate,double com)
{
    u[tot]=x;v[tot]=y;r[tot]=rate;c[tot]=com;
    next[tot]=first[x];
    first[x]=tot++;
}
int main()
{
    scanf("%d%d%d%lf",&n,&m,&s,&vv);
    memset(first,-1,sizeof(first));tot=0;
    for(int i=0;i<m;i++)
    {
        int x,y;double rr,cc;
        scanf("%d%d%lf%lf",&x,&y,&rr,&cc);
        add(x,y,rr,cc);
        scanf("%lf%lf",&rr,&cc);
        add(y,x,rr,cc);
    }
    for(int i=1;i<=n;i++)d[i]=INF;
    if(!poscir())printf("NO\n");
    else  printf("YES\n");
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值