HDU 1757解题报告

A Simple Math Problem

                                 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                      Total Submission(s): 2959    Accepted Submission(s): 1779


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 

Author
linle
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3117  2256  2254  2294  2971 

         这道题是比较水的矩阵快速幂,直接给出了线性递推式,直接构造。

        参考代码:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<ctime>
#include<cstdlib>
#include<iomanip>
#include<utility>
#define pb push_back
#define mp make_pair
#define CLR(x) memset(x,0,sizeof(x))
#define _CLR(x) memset(x,-1,sizeof(x))
#define REP(i,n) for(int i=0;i<n;i++)
#define Debug(x) cout<<#x<<"="<<x<<" "<<endl
#define REP(i,l,r) for(int i=l;i<=r;i++)
#define rep(i,l,r) for(int i=l;i<r;i++)
#define RREP(i,l,r) for(int i=l;i>=r;i--)
#define rrep(i,l,r) for(int i=1;i>r;i--)
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<11
using namespace std;
int k,m;
struct mat
{
    int d[15][15];
} A,B,E;

mat multi(mat a,mat b)
{
    mat ans;
    rep(i,0,10)
    {
        rep(j,0,10)
        {
            ans.d[i][j]=0;
            rep(k,0,10)
                ans.d[i][j]+=a.d[i][k]*b.d[k][j];
            ans.d[i][j]%=m;
        }
    }
    return ans;
}

mat quickmulti(mat a,int k)
{
    if(k==0) return E;
    if(k==1) return a;
    mat ans=E;
    while(k)
    {
        if(k&1)
        {
            k--;
            ans=multi(ans,a);
        }
        else
        {
            k>>=1;
            a=multi(a,a);
        }
    }
    return ans;
}

int main()
{
    CLR(E.d);
    rep(i,0,10)
    E.d[i][i]=1;
    while(~scanf("%d%d",&k,&m))
    {
        if(k<10)
        {
            printf("%d\n",k%m);
            continue;
        }
        CLR(A.d);CLR(B.d);
        rep(i,1,10)
            A.d[i][i-1]=1;
        rep(i,0,10)
            read(A.d[0][i]);
        rep(i,0,10)
            B.d[i][0]=9-i;
        mat m1=quickmulti(A,k-9);
        m1=multi(m1,B);
        printf("%d\n",m1.d[0][0]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值