HDU 1704解题报告

Rank

                                               Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                          Total Submission(s): 1179    Accepted Submission(s): 439


Problem Description
there are N ACMers in HDU team.
ZJPCPC Sunny Cup 2007 is coming, and lcy want to select some excellent ACMers to attend the contest. There have been M matches since the last few days(No two ACMers will meet each other at two matches, means between two ACMers there will be at most one match). lcy also asks"Who is the winner between A and B?" But sometimes you can't answer lcy's query, for example, there are 3 people, named A, B, C.and 1 match was held between A and B, in the match A is the winner, then if lcy asks "Who is the winner between A and B", of course you can answer "A", but if lcy ask "Who is the winner between A and C", you can't tell him the answer.
As lcy's assistant, you want to know how many queries at most you can't tell lcy(ask A B, and ask B A is the same; and lcy won't ask the same question twice).
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
Each case first contains two integers N and M(N , M <= 500), N is the number of ACMers in HDU team, and M is the number of matchs have been held.The following M lines, each line means a match and it contains two integers A and B, means A wins the match between A and B.And we define that if A wins B, and B wins C, then A wins C.
 

Output
For each test case, output a integer which represent the max possible number of queries that you can't tell lcy.
 

Sample Input
  
  
3 3 3 1 2 1 3 2 3 3 2 1 2 2 3 4 2 1 2 3 4
 

Sample Output
  
  
0 0 4
Hint
in the case3, if lcy ask (1 3 or 3 1) (1 4 or 4 1) (2 3 or 3 2) (2 4 or 4 2), then you can't tell him who is the winner.
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1703  1700  1701  1706  1702 


                   这道题是为了练习floyd算法求传递闭包。只需注意一些小细节即可。

             参考代码:

             

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#define pb push_back
#define CLR(x) memset(x,0,sizeof(x))
#define __CLR(x) memset(x,-1,sizeof(x))
using namespace std;

int t,n,m;
int g[605][605];
void floyd()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(g[j][i])
            {
                for(int k=1;k<=n;k++)
                {
                    if(g[i][k])
                        g[j][k]=1;
                }
            }
        }
    }
}

int main()
{
   
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d%d",&n,&m);
       CLR(g);
       while(m--)
       {
           int u,v;
           scanf("%d%d",&u,&v);
           g[u][v]=1;
       }
       floyd();
       int cnt=n*(n-1);
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=n;j++)
           {
               if(i!=j&&g[i][j])
                  cnt-=2;
           }
       }
       printf("%d\n",cnt/2);
   }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值