HDU 1856 More is better

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

 

 

Sample Input

 

4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

 

 

Sample Output

 

4

2

 

题意:给你一大堆人的关系,要你求出最多能留下多少人(留下的人必须是朋友)

思路:按照并查集的性质,每次遇到有关系的人,检查一下2人是否已经在前面的关系网中出现了,如果没出现,就加上2人当前的集合,详细过程请看代码

AC代码:

 

#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 100010
int f[N],maxx[N];
bool cmp(int x,int y)
{
    return  x>y;
}
int find(int x)
{
    if(x!=f[x])
        f[x]=find(f[x]);
    return f[x];
}
void make(int x,int y)
{
    int a,b;
    a=find(x);
    b=find(y);
    if(a!=b)    //如果不相等
    {
        f[a]=b;
        maxx[a]+=maxx[b];   //那么就让集合变为2个集合的和
        maxx[b]=maxx[a];
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<N;i++){
            f[i]=i;         
            maxx[i]=1;      //先让每个人在不同的集合中,所以集合的初值是1
        }
        while(n--)
        {
            int a,b;
            scanf("%d %d",&a,&b);   //输入有朋友关系的人
            make(a,b);
        }
        sort(maxx,maxx+N,cmp);  //排序
        printf("%d\n",maxx[0]);     //输出最大的解
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值