poj 1502 MPI Maelstrom

MPI Maelstrom

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 2367

 

Accepted: 1390

Description

BIT has recently takendelivery of their new supercomputer, a 32 processor Apollo Odyssey distributedshared memory machine with a hierarchical communication subsystem. ValentineMcKee's research advisor, Jack Swigert, has asked her to benchmark the newsystem. 
``Since the Apollo is a distributed shared memory machine, memory access andcommunication times are not uniform,'' Valentine told Swigert. ``Communicationis fast between processors that share the same memory subsystem, but it isslower between processors that are not on the same subsystem. Communicationbetween the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?''Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from oneprocessor to all the other n-1 processors, they just do a sequence of n-1sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent themessage to another, those two can then send messages to two other hosts at thesame time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our networkthat we should exploit. The interface cards we have allow each processor tosimultaneously send messages to any number of the other processors connected toit. However, the messages don't necessarily arrive at the destinations at thesame time -- there is a communication cost involved. In general, we need totake into account the communication costs for each link in our networktopologies and plan accordingly to minimize the total time required to do abroadcast.''

Input

The input will describethe topology of a network connecting n processors. The first line of the inputwill be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix issquare and of size n x n. Each of its entries will be either an integer or thecharacter x. The value of A(i,j) indicates the expense of sending a messagedirectly from node i to node j. A value of x for A(i,j) indicates that amessage cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require networkcommunication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume thatthe network is undirected (messages can go in either direction with equal overhead),so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lowertriangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is,the second line of input will contain one entry, A(2,1). The next line willcontain two entries, A(3,1) and A(3,2), and so on.

Output

Your program shouldoutput the minimum communication time required to broadcast a message from thefirst processor to all the other processors.

Sample Input

5

50

30 5

100 20 50

10 x x 10

Sample Output

35

题目就是Dijkstra算法题, 题意就是求第一个点到各个点最短路径中的最大值。

  学到直接把字符串改为整型,长整型:

atof()             将字符串转换成浮点数值 
atoi()                 将字符串转换成整数值 
atol()                 将字符串转换成长整数值 
strtod()             将字符串转换成双精度型数值 
strtol()             将字符串转换成长型数值 

输入的时候需要用到的小技巧,直接调用void dijkstra()就可以 了。。。

#include<cstdio>

#include<iostream>

#include<string>

#include<cstring>

#include<algorithm>

#include<iostream>

#include<stdio.h>

#include<algorithm>

#include<string.h>

#include<stdlib.h>

using namespace std;

# define INF  999999999;

const int maxn=1000;

intdis[maxn],g[maxn][maxn],n;

bool v[maxn];

char t[maxn];

int min(int a,intb){

    return a<b?a:b;

}

 

int main(){

    while(cin>>n){

         for(int i=1;i<=n;i++){

            for(int j=1;j<=n;j++){

                if(i==j){

                    g[i][j]=0;

                    //g[j][i]=0;

                }

                else{

                    g[i][j]=INF;

                    //g[j][i]=INF;

                }

            }

         }

         for(int i=2;i<=n;i++){

            for(int j=1;j<=i-1;j++){

                scanf("%s",&t);

                if(t[0]=='x'){

                    g[j][i]=INF;

                    g[i][j]=INF;

                }

                else{

                   g[j][i]=atoi(t);  // atoi();将字符串转为整型。

                   g[i][j]=atoi(t);

                }

            }

 

         }

         for(int i=1;i<=n;i++){

         dis[i]=INF;

         }

         dis[1]=0;

         memset(v,0,sizeof v);

         for(int i=1;i<=n;i++){

            int mark=-1,mindis=INF;

            for(int j=1;j<=n;j++){

               if(!v[j]&&dis[j]<mindis){

                    mindis=dis[j];

                    mark=j;

                }

            }

            v[mark]=1;

            for(int j=1;j<=n;j++){

                if(!v[j]){

                   dis[j]=min(dis[j],dis[mark]+g[mark][j]);

                }

            }

         }

 

         /*for(int j=1;j<=n;j++){

            cout<<dis[j]<<endl;

         }*/

         int themax=0;

         for(int j=2;j<=n;j++){

            if(themax<dis[j])

                themax=dis[j];

         }

         printf("%d\n",themax);

    }

 

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值