Coordinates

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
Give you two integers P and Q. Let all divisors of P be X-coordinates. Let all divisors of Q be Y-coordinates.

For example, when P=6 and Q=2, we can get the coordinates (1,1) (1,2) (2,1) (2,2) (3,1) (3,2) (6,1) (6,2).

You should print all possible coordinates in the order which is first sorted by X-coordinate when coincides, sorted by Y-coordinate.

输入
One line with two integers P and Q(1 <= P, Q <= 10000).

输出
The output may contains several lines , each line with two integers Xi and Yi, denoting the coordinates.

样例输入
6 2
样例输出
1 1
1 2
2 1
2 2
3 1
3 2
6 1
6 2

#include "iostream"
#include "cmath"
#include "algorithm"
using namespace std;

int p, q;
int divP[1000];
int divQ[1000];

int yueShu(int n, int *div)
{
    int u = 0;
    for(int i=1; i<=sqrt(n); i++)
    {
        if(n%i == 0)
        {
            div[u++] = i;
            if(n/i > i)  //防止平方数的根被加入2次
                div[u++] = n/i;
        }
    }
    return u;
}

int main()
{
    int i, j;
    cin >> p >> q;
    int n1 = yueShu(p, divP); 
    int n2 = yueShu(q, divQ);
    sort(divP, divP+n1);
    sort(divQ, divQ+n2);
    for(i=0; i<n1; i++)
        for(j=0; j<n2; j++)
            cout << divP[i] << " " << divQ[j] << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值