HDU2660:Accepted Necklace(DFS)

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
 

Input
The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 
 

Output
For each case, output the highest possible value of the necklace.
 

Sample Input
  
  
1 2 1 1 1 1 1 3
 

Sample Output
  
  
1


数据量不大,应该dfs也可破,

准确来说是属于二维费用的背包问题 


<pre name="code" class="cpp">#include<stdio.h>

int ans,n,k,weight;
int vis[50];
struct node
{
	int val,wei;
}s[50];

void dfs(int v,int w,int num,int step)
{
	if (num==k||w==weight)
	{
		if(ans<v)
			ans=v;
		return;
	}
	for(int i=step;i<=n;++i)
	{
		if(!vis[i]&&num+1<=k&&w+s[i].wei<=weight)
		{
			vis[i]=1;
			dfs(v+s[i].val,w+s[i].wei,num+1,i+1);
			vis[i]=0;
		}
	}
	return ;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&k);
		for(int i=1;i<=n;++i)
		{
			scanf("%d%d",&s[i].val,&s[i].wei);
			vis[i]=0;
		}
		scanf("%d",&weight);
		ans=0;
		dfs(0,0,0,1);
		printf("%d\n",ans);
	}
	return 0;
}


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值