hdu 1698 Just a Hook 线段树

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

if(p[step].value)

                p[2*step].value=p[2*step+1].value=p[step].value;

这个代码必须写在前面,不然又这种情况出现:

1 5 2

5 9 3

当第二次操作对5时,此时5的值为3改变,之后又回到【4,5】,经过if(p[step].value)
                p[2*step].value=p[2*step+1].value=p[step].value;

操作  5的值变为2;一定要按思路的顺序去写,不然就很容易出错

下面我的代码

#include<stdio.h>
#include<string.h>
int a[100002];
struct ele
{
    int left;
    int right;
    int value;
}p[401111];
void build(int L,int R,int step)
{
    p[step].left=L;
    p[step].right=R;
    if(L==R)
        p[step].value=1;
    else
    {
        int Mid=(L+R)/2;
        build(L,Mid,2*step);
        build(Mid+1,R,2*step+1);
        p[step].value=0;
    }
}
void update(int L,int R,int value,int step)
{
    if(p[step].left==L&&p[step].right==R)
         p[step].value=value;
    else
    {
        if(p[step].value)
                p[2*step].value=p[2*step+1].value=p[step].value;
        int Mid=(p[step].left+p[step].right)/2;
        if(R<=Mid)
        {
            update(L,R,value,2*step);


            p[step].value=0;
        }
        else
        if(L>=Mid+1)
        {
            update(L,R,value,2*step+1);
            p[step].value=0;
        }
        else
        {
            update(L,Mid,value,2*step);
            update(Mid+1,R,value,2*step+1);
            p[step].value=0;
        }


    }
}
int sum(int x,int y,int step)
{
    if(p[step].value!=0)
    {
        return (y-x+1)*p[step].value;
    }


    else
    {
        int Mid=(p[step].left+p[step].right)/2;
        return sum(x,Mid,2*step)+sum(Mid+1,y,2*step+1);
    }
}
int main()
{
    int n,i,m,k;
    int t=0;
    int x,y,z;
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            a[i]=1;
        build(1,n,1);
        scanf("%d",&k);
        while(k--)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(x,y,z,1);
           // sum(1,n,1);
        }
        printf("Case %d:",++t);
        printf(" The total value of the hook is %d.\n",sum(1,n,1));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值