Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
Sample Input
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
Sample Output
100 90 7
Source
这题 花费了我一天的时间,以后要好好看看
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int dp[60000][12];
int Map[12][12];
int s[12];
int tir[60000][12];
int n,m;
void Init()
{
int i,j,t;
s[0]=1;
for(i=1;i<11;i++)
s[i]=s[i-1]*3;
for(i=0;i<s[10];i++)
{
t=i;
for(j=0;j<10;j++)
{
tir[i][j]=t%3;
t/=3;
}
}
}
int main()
{
int i,j,k;
Init();
int x,y,z;
bool Flag;
int ans;
int L;
while(scanf("%d%d",&n,&m)!=EOF)
{
ans=INF;
memset(Map,INF,sizeof(Map));
memset(dp,INF,sizeof(dp));
while(m--)
{
scanf("%d%d%d",&x,&y,&z);
if(Map[x-1][y-1]>z)
Map[y-1][x-1]=Map[x-1][y-1]=z;
}
for(i=0;i<n;i++)
dp[s[i]][i]=0;
for(i=0;i<s[n];i++)
{
Flag=true;
for(j=0;j<n;j++)
{
if(tir[i][j]==0)
Flag=false;
if(dp[i][j]==INF)
continue;
for(k=0;k<n;k++)
{
if(k==j)
continue;
if(tir[i][k]==2)
continue;
if(Map[j][k]==INF)
continue;
L=i+s[k];
dp[L][k]=min(dp[L][k],dp[i][j]+Map[j][k]);
}
}
if(Flag)
{
for(k=0;k<n;k++)
ans=min(ans,dp[i][k]);
}
}
if(ans==INF)
printf("-1\n");
else
printf("%d\n",ans);
}
return 0;
}
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int dp[60000][12];
int Map[12][12];
int s[12];
int tir[60000][12];
int n,m;
void Init()
{
int i,j,t;
s[0]=1;
for(i=1;i<11;i++)
s[i]=s[i-1]*3;
for(i=0;i<s[10];i++)
{
t=i;
for(j=0;j<10;j++)
{
tir[i][j]=t%3;
t/=3;
}
}
}
int main()
{
int i,j,k;
Init();
int x,y,z;
bool Flag;
int ans;
int L;
while(scanf("%d%d",&n,&m)!=EOF)
{
ans=INF;
memset(Map,INF,sizeof(Map));
memset(dp,INF,sizeof(dp));
while(m--)
{
scanf("%d%d%d",&x,&y,&z);
if(Map[x-1][y-1]>z)
Map[y-1][x-1]=Map[x-1][y-1]=z;
}
for(i=0;i<n;i++)
dp[s[i]][i]=0;
for(i=0;i<s[n];i++)
{
Flag=true;
for(j=0;j<n;j++)
{
if(tir[i][j]==0)
Flag=false;
if(dp[i][j]==INF)
continue;
for(k=0;k<n;k++)
{
if(k==j)
continue;
if(tir[i][k]==2)
continue;
if(Map[j][k]==INF)
continue;
L=i+s[k];
dp[L][k]=min(dp[L][k],dp[i][j]+Map[j][k]);
}
}
if(Flag)
{
for(k=0;k<n;k++)
ans=min(ans,dp[i][k]);
}
}
if(ans==INF)
printf("-1\n");
else
printf("%d\n",ans);
}
return 0;
}