poj 1151 Atlantis 离散化+线段树

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

Source

先离散平行y轴的线段,之后排序建立线段树,然后再把平行于x轴的线段离散,之后排序,最后得出面积,离散后都是点;

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
struct ele
{
double x;
double y1;
double y2;
int flag;
}set[500];
double T[500];
struct Ele
{
int left;
int right;
double y1;
double y2;
int flag;
double len;
}p[1500];
bool cmp(ele x,ele y)
{
return x.x-y.x<0.000001;
}
void build(int x,int y,int step)
{
p[step].left=x;
p[step].right=y;
p[step].y1=T[x];
p[step].y2=T[y];
p[step].flag=0;
p[step].len=0;
if(x==y-1)
return;
else
{
int Mid=(x+y)/2;
build(x,Mid,2*step);
build(Mid,y,2*step+1);
}
}
void college(int step)
{
if(p[step].flag>0)
p[step].len=p[step].y2-p[step].y1;
else
if(p[step].right-p[step].left==1)
p[step].len=0;
else
p[step].len=p[step*2].len+p[2*step+1].len;
return;
}
void update(int step,ele s)
{
if(s.y1==p[step].y1&&s.y2==p[step].y2)
{
p[step].flag+=s.flag;
college(step);
return;
}
else
{
if(p[2*step].y2>=s.y2)
update(2*step,s);
else
if(p[2*step+1].y1<=s.y1)
update(2*step+1,s);
else
{
ele temp=s;
temp.y2=p[2*step].y2;
update(2*step,temp);
temp=s;
temp.y1=p[2*step+1].y1;
update(2*step+1,temp);
}
college(step);
return ;
}
}
int main()
{
int ans;
int n;
int i;
int t;
ans=0;
double x1,y1,x2,y2;
while(scanf("%d",&n),n)
{
ans++;
t=1;
for(i=1;i<=n;i++)
{
scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
set[t].x=x1;
set[t].y1=y1;
set[t].y2=y2;
set[t].flag=1;
T[t++]=y1;
set[t].x=x2;
set[t].y1=y1;
set[t].y2=y2;
set[t].flag=-1;
T[t++]=y2;
}
sort(set+1,set+t,cmp);
sort(T+1,T+t);
build(1,t-1,1);
update(1,set[1]);
double sum=0;
for(i=2;i<t;i++)
{
sum+=p[1].len*(set[i].x-set[i-1].x);
update(1,set[i]);
}
printf("Test case #%d\nTotal explored area: %.2lf\n\n",ans,sum);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值