uva 10881 Piotr'sAnts

Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontalpole L cm long. Each ant is facing either left or right and walksat a constant speed of 1 cm/s. When two ants bump into each other, theyboth turn around (instantaneously) and start walking in opposite directions.Piotr knows where each of the ants starts and which direction it is facingand wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, N. Ntest cases follow. Each one starts with a line containing 3 integers:L , T and n (0 <= n <= 10000) .The next n lines give the locations of the n ants (measuredin cm from the left end of the pole) and the direction they are facing(L or R).

Output
For each test case, output one line containing "Case #x:"followed by n lines describing the locations and directions of then ants in the same format and order as in the input. If two or moreants are at the same location, print "Turning" instead of "L" or "R" fortheir direction. If an ant falls off the pole before T seconds,print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R


Problemsetter: Igor Naverniouk

Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev


#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn = 10000+5;

struct ants
{
	int posi;
	int id;
	int d;
	bool operator < (const ants& a) const 
	{
		return  posi < a.posi;
	}
} before[maxn],after[maxn];

const char dirname [] [10]={"L","Turning","R"};


int order[maxn];

int main()
{
	int k;
	cin>>k;
	for(int z=1;z<=k;z++)
	{
		int l,t,n;
		scanf("%d%d%d",&l,&t,&n);
		for(int i=0;i<n;i++)
		{
			int p,d;
			char c;
			scanf("%d %c",&p,&c);
			d=(c=='L'?-1:1);
			before[i]=(ants){p,i,d};
			after[i]=(ants){p+t*d,0,d};
		}
		
		
		sort(before,before+n);
		for(int i=0;i<n;i++)
		order[before[i].id]=i;
		
		sort(after,after+n);
		for(int i=0;i<n-1;i++)
		if(after[i].posi==after[i+1].posi)
		after[i].d=after[i+1].d=0;
		
		printf("Case #%d:\n",z);
		for(int i=0;i<n;i++)
		{
			int a=order[i];
			if(after[a].posi<0||after[a].posi>l)
			printf("Fell off\n");
			else
			printf("%d %s\n",after[a].posi,dirname[after[a].d+1]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值