2014 Multi-University Training Contest 1 - 1004 / hdu 4864 Task

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1988    Accepted Submission(s): 514


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 

Author
FZU
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4871  4870  4869  4868  4867 

官方题解:

D. Task

基本思想是贪心。

对于价值c=500*xi+2*yiyi最大影响100*2<500,所以就是求xi总和最大。可以先对机器和任务的时间从大到小排序。从最大时间的任务开始,找出满足任务时间要求的所有机器,从中找出等级最低且满足任务等级要求的机器匹配。依次对任务寻找满足要求的机器。


这是多校里边憋了半天也没出的一道题,结果发现和自己的想法很相似,大牛的代码看起来很简单,为毛自己做不到呢,加油啦!!!
其实代码很好懂,在mulitiset二分查找匹配机器,而任务是用线性的遍历就够了:

 
/*
Problem : 4864 ( Task )     Judge Status : Accepted
RunId : 11153650    Language : G++    Author : motefly
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
using namespace std;
const int maxn=100005;
pair<int,int>ma[maxn],ta[maxn];
multiset<int > s;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        s.clear();
        for(int i=0;i<n;i++)
            scanf("%d%d",&ma[i].first,&ma[i].second);
        for(int i=0;i<m;i++)
            scanf("%d%d",&ta[i].first,&ta[i].second);
        sort(ma,ma+n,greater< pair<int,int> > ());
        sort(ta,ta+m,greater< pair<int,int> > ());
        int cnt=0;
        long long ans=0;
        for(int i=0,j=0;i<m;i++)
        {
            while(j<n&&ma[j].first>=ta[i].first)
                s.insert(ma[j++].second);
            multiset<int>::iterator it=s.lower_bound(ta[i].second);
            if(it!=s.end())
            {
                ++cnt;
                ans+=500*ta[i].first+2*ta[i].second;
                s.erase(it);
            }
        }
        cout<<cnt<<' '<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值