2014 Multi-University Training Contest 2 - 1011 / hdu 4882 ZCC Loves Codefires

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 71    Accepted Submission(s): 38


Problem Description
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
But why?
Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.
Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).
 

Input
The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
The last line contains N integers Ki(1≤Ki≤10^4), as was described.
 

Output
One integer L, the minimal score he will lose.
 

Sample Input
  
  
3 10 10 20 1 2 3
 

Sample Output
  
  
150
Hint
Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second. L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.
 

Author
镇海中学
 

Source
 

Recommend
 
这道题在第六分钟就被电子科大A了,菜鸟们想了许久才有眉目,我却被自己坑了。。。
看题解是:

考察序列中相邻的两题i, j(i在前)。交换它们后,解出它们之前的题目所带来的时间对答案的贡献是不变的,它们对它们后面的题目的贡献也是不变的,其他题目之间对答案的贡献自然也是不变的。唯一的变化就是,原来的EiKj一项变成了EjKi一项。那么,为了使答案变优,需要满足的条件是EjKiEiKj。也即Ei/KiEj/Kj

那么,最优解序列Ai一定满足,EAi/KAi是递增的。

排序一遍即可。


AC代码是:
/*
Accepted 1011 796MS 1912K G++ 
*/
/**

吉林大学
Jilin U

Statement:  以下代码完全由作者个人完成,不存在抄袭、套用。
Author:     xuzhenhui
Date:       2014-07-22
Usage:      多校第一场1004

**/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100005;
//#define __int64 long long
struct node
{
    long long b,t;
};
node a[maxn];
bool cmp(const node &a,const node &x)
{
    return double(a.t)/a.b<double(x.t)/x.b;

}
int main()
{
    long long n,sum=0;
    long long ans=0;
    cin>>n;
    for(long long i=0;i<n;i++)
        cin>>a[i].t;
    for(long long i=0;i<n;i++)
        cin>>a[i].b;
    sort(a,a+n,cmp);
    for(long long i=0;i<n;i++)
    {
        sum+=a[i].t;
        ans+=a[i].b*sum;
    }
    cout<<ans<<endl;
    return 0;
}

那什么,别用cout cin会快点的
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值