模拟日历计算 poj1008

Maya Calendar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 69932 Accepted: 21524

Description

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. 

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. 

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . 

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was: 

Haab: 0. pop 0 

Tzolkin: 1 imix 0 
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar. 

Input

The date in Haab is given in the following format: 
NumberOfTheDay. Month Year 

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000. 

Output

The date in Tzolkin should be in the following format: 
Number NameOfTheDay Year 

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates. 

Sample Input

3
10. zac 0
0. pop 0
10. zac 1995

Sample Output

3
3 chuen 0
1 imix 0

9 cimi 2801

题意:看了我近半小时Orz 英语太弱了

玛雅人有两种纪年:haab 和 holly

haab : 365天

19个月 最后一个uayet月 只有5天

holly

260天

13个月

每月都是20天

总的天数sum%13+1 为日期

sum%20+1 为月份

sum/260为年份

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int init_Haab(char *s)
{
    if(strcmp(s,"pop")==0)
        return 1;
    else if(strcmp(s,"no")==0)
        return 2;
    else if(strcmp(s,"zip")==0)
        return 3;
    else if(strcmp(s,"zotz")==0)
        return 4;
    else if(strcmp(s,"tzec")==0)
        return 5;
    else if(strcmp(s,"xul")==0)
        return 6;
    else if(strcmp(s,"yoxkin")==0)
        return 7;
    else if(strcmp(s,"mol")==0)
        return 8;
    else if(strcmp(s,"chen")==0)
        return 9;
    else if(strcmp(s,"yax")==0)
        return 10;
    else if(strcmp(s,"zac")==0)
        return 11;
    else if(strcmp(s,"ceh")==0)
        return 12;
    else if(strcmp(s,"mac")==0)
        return 13;
    else if(strcmp(s,"kankin")==0)
        return 14;
    else if(strcmp(s,"muan")==0)
        return 15;
    else if(strcmp(s,"pax")==0)
        return 16;
    else if(strcmp(s,"koyab")==0)
        return 17;
    else if(strcmp(s,"cumhu")==0)
        return 18;
    else if(strcmp(s,"uayet")==0)
        return 19;
}

int sumday(int d,int m,int y)
{
    int sum=0;
    for(int i=1;i<=y;i++)
        sum+=365;
    for(int i=1;i<m;i++)//千万注意
        sum+=20;
    return sum+d;
}
// imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau
char str[25][10]={"0","imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
int main()
{
    int t;
    scanf("%d",&t);
    printf("%d\n",t);
    while(t--)
    {
        int d,y;
        char s[10];
        scanf("%d. %s %d",&d,s,&y);

        int sum = sumday(d,init_Haab(s),y);
        int hd=sum%13+1;
        int hm=sum%20+1;
        int hy=sum/260;

        printf("%d %s %d\n",hd,str[hm],hy);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值