统计难题
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 13765 Accepted Submission(s): 5904
Total Submission(s): 13765 Accepted Submission(s): 5904
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.
注意:本题只有一组测试数据,处理到文件结束.
注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm
ba
b
band
abc
band
bee
absolute
acm
ba
b
band
abc
Sample Output
2
3
1
0
3
1
0
先给出若干个字符序列{s1,s2,....sn},然后对于字符串s,求算在{s1,s2,s3...sn}中有多少字符序列是以s为前缀的。
公共前缀-------------------Trie树。。。。
公共前缀-------------------Trie树。。。。
/*************************************************************************
* author:crazy_石头
* algorithm:Trie
* date:2013/09/29
**************************************************************************/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct TrieNode
{
int cnt;
TrieNode* next[26];
};
TrieNode* root=new TrieNode;
void build(char* s)
{
TrieNode* p=root,*node;
int len=strlen(s);
for(int i=0;i<len;i++)
{
if(!p->next[s[i]-'a'])
{
node=new TrieNode;
for(int j=0;j<26;j++)
node->next[j]=NULL;
node->cnt=1;
p->next[s[i]-'a']=node;
p=node;
}
else
{
p=p->next[s[i]-'a'];
p->cnt++;
}
}
}
int Search(char* s)
{
TrieNode* p=root;
int len=strlen(s);
for(int i=0;i<len;i++)
if(!p->next[s[i]-'a'])
{
return 0;
}
else
{
p=p->next[s[i]-'a'];
}
return p->cnt;
}
void Del(TrieNode* p)
{
for(int i=0;i<26;i++)
{
if(p->next[i]!=NULL)
Del(p->next[i]);
}
free(p);
}
int main()
{
char s[20];
for(int i=0;i!=26;i++)
root->next[i]=NULL;
root->cnt=0;
while(gets(s))
{
if(!strcmp(s,""))
break;
build(s);
}
while(scanf("%s",s)!=EOF)
{
printf("%d\n",Search(s));
}
return 0;
}