交叉染色法判定二分图

Divide Groups

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 916    Accepted Submission(s): 322


Problem Description

  This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos.
  After carefully planning, Tom200 announced his activity plan, one that contains two characters:
  1. Whether the effect of the event are good or bad has nothing to do with the number of people join in.
  2. The more people joining in one activity know each other, the more interesting the activity will be. Therefore, the best state is that, everyone knows each other.
  The event appeals to a great number of alumnus, and Tom200 finds that they may not know each other or may just unilaterally recognize others. To improve the activities effects, Tom200 has to divide all those who signed up into groups to take part in the activity at different time. As we know, one's energy is limited, and Tom200 can hold activity twice. Tom200 already knows the relationship of each two person, but he cannot divide them because the number is too large.
  Now Tom200 turns to you for help. Given the information, can you tell if it is possible to complete the dividing mission to make the two activity in best state.

Input
  The input contains several test cases, terminated by EOF.
  Each case starts with a positive integer n (2<=n<=100), which means the number of people joining in the event.
  N lines follow. The i-th line contains some integers which are the id
of students that the i-th student knows, terminated by 0. And the id starts from 1.

Output
  If divided successfully, please output "YES" in a line, else output "NO".

Sample Input
  
  
3 3 0 1 0 1 2 0

Sample Output
YES

 

裸题。。。。

/****************************************
* author:crazy_石头
* algorithm:交叉染色法判定二分图
* date:2013/10/17
* 条件:
* 1、不存在环
* 2、图是连通图
* 3、双向图

*思路:
*任意取一个点进行染色,如果发现要涂某一块时这个块已经被涂了色,并且与我们要使用的颜色不同的话,就说明这个图不能被染成BICOLORABLE的。
*(1)如果没有染色,将它染色,并将它周围的点变成相反色。
*(2)如果已经染色,判断是否与现在染色的点的颜色相同,相同,则退出,否则继续。
*****************************************/
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cstring>
#include<climits>

using namespace std;

#define N 90005
#define M 4000005
#define INF INT_MAX

const int maxn=100+10;
int map[maxn][maxn];
int cnt;
int head[maxn],color[maxn];

inline int max(int a,int b)
{
    return a>b?a:b;
}

inline int min(int a,int b)
{
    return a<b?a:b;
}

struct Edge
{
    int to,next;
}edge[maxn*maxn];

inline void addedge(int u,int v)
{
    edge[cnt].to=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}

inline void makemap(int u,int v)
{
    addedge(u,v);
    addedge(v,u);
}

inline bool dfs(int u,int colour)
{
    color[u]=colour;
    for(int i=head[u];~i;i=edge[i].next)
    {
        int v=edge[i].to;
        if(color[v]!=-1)
        {
            if(color[v]==colour)
                return false;
            continue;
        }
        if(!dfs(v,!colour))
            return false;
    }
    return true;
}

inline void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(color,-1,sizeof(color));
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int temp;
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        {
            while(scanf("%d",&temp)&&temp)
            map[i][temp]=1;
        }
        init();

        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if(map[i][j]==0||map[j][i]==0)
                {
                    makemap(i,j);
                }
            }
        }
        int ok=1;
        for(int i=1;i<=n;i++)
        {
            if(color[i]==-1&&!dfs(i,0))
            {
                ok=0;
                break;
            }
        }
        ok==1?puts("YES"):puts("NO");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值