POJ 2955 区间dp

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2446 Accepted: 1258

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


题意:求最长合法括号序列,

两种写法:

/* ***********************************************
Author :rabbit
Created Time :2014/3/10 19:03:58
File Name :A.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
int dp[300][300];
char str[400];
bool match(char a,char b){
	if(a=='('&&b==')')return 1;
	if(a=='['&&b==']')return 1;
	return 0;
}
int main(){
	while(~scanf("%s",str)&&str[0]!='e'){
		int len=strlen(str);
		memset(dp,0,sizeof(dp));
		for(int i=0;i+1<len;i++)
			if(match(str[i],str[i+1]))dp[i][i+1]++;
		for(int k=2;k<len;k++)
		   for(int i=0;i<len-k;i++){
			   int j=i+k;
			   if(match(str[i],str[j]))dp[i][j]=dp[i+1][j-1]+1;
			   for(int g=i;g<j;g++)
				   dp[i][j]=max(dp[i][j],dp[i][g]+dp[g+1][j]);
		   }
		cout<<2*dp[0][len-1]<<endl;
	}
	return 0;
}

/* ***********************************************
Author :rabbit
Created Time :2014/3/10 19:03:58
File Name :A.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
int dp[300][300];
char str[400];
int dfs(int l,int r){
	int &res=dp[l][r];
	if(res!=-1)return res;
	if(r-l<2)return res=0;
	for(int i=l+1;i<r;i++)
		res=max(res,dfs(l,i)+dfs(i,r));
	if((str[l]=='('&&str[r-1]==')')||(str[l]=='['&&str[r-1]==']'))
		res=max(res,dfs(l+1,r-1)+2);
	return res;
}
int main()
{
     //freopen("data.in","r",stdin);
     //freopen("data.out","w",stdout);
     while(~scanf("%s",str)){
		 if(strcmp(str,"end")==0)break;
		 int len=strlen(str);
		 memset(dp,-1,sizeof(dp));
		 int res=dfs(0,len);
		 if(res==-1)res=0;
		 cout<<res<<endl;
	 }
     return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值