POJ 1379 模拟退火法

Run Away
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5631 Accepted: 1728

Description

One of the traps we will encounter in the Pyramid is located in the Large Room. A lot of small holes are drilled into the floor. They look completely harmless at the first sight. But when activated, they start to throw out very hot java, uh ... pardon, lava. Unfortunately, all known paths to the Center Room (where the Sarcophagus is) contain a trigger that activates the trap. The ACM were not able to avoid that. But they have carefully monitored the positions of all the holes. So it is important to find the place in the Large Room that has the maximal distance from all the holes. This place is the safest in the entire room and the archaeologist has to hide there.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing three integers X, Y, M separated by space. The numbers satisfy conditions: 1 <= X,Y <=10000, 1 <= M <= 1000. The numbers X and Yindicate the dimensions of the Large Room which has a rectangular shape. The number M stands for the number of holes. Then exactly M lines follow, each containing two integer numbers Ui and Vi (0 <= Ui <= X, 0 <= Vi <= Y) indicating the coordinates of one hole. There may be several holes at the same position.

Output

Print exactly one line for each test case. The line should contain the sentence "The safest point is (P, Q)." where P and Qare the coordinates of the point in the room that has the maximum distance from the nearest hole, rounded to the nearest number with exactly one digit after the decimal point (0.05 rounds up to 0.1).

Sample Input

3
1000 50 1
10 10
100 100 4
10 10
10 90
90 10
90 90
3000 3000 4
1200 85
63 2500
2700 2650 
2990 100

Sample Output

The safest point is (1000.0, 50.0).
The safest point is (50.0, 50.0).
The safest point is (1433.0, 1669.8).

在给定范围内找一个点,距离所有点的最小值最大,

做过类似题目,但是发现以前的方法行不通了,看别人的写法,先找20个随机种子,然后逐步更新,最后取最优解。学习了。

代码:

/* ***********************************************
Author :_rabbit
Created Time :2014/5/11 21:41:17
File Name :3.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
struct point  
{  
       double x,y,dis;  
}a[2000],b[100],ans;  
int n,X,Y;  
double dis(point c){  
       double sum=1e8;  
       for (int i=1;i<=n;++i){
		   double dd=sqrt((c.x-a[i].x)*(c.x-a[i].x)+(c.y-a[i].y)*(c.y-a[i].y));
		   if(sum>dd)sum=dd;
	   }  
       return sum;  
}  
void Solve()  
{  
    for (int i=1;i<=20;++i)      
    {  
        b[i].x=rand()%X+1,b[i].y=rand()%Y+1;  
        b[i].dis=dis(b[i]);  
    }  
    point t;  
    for (double i=max(X,Y);i>=1e-2;i*=0.9)        
        for (int j=1;j<=20;j++)                  
            for (int k=1;k<=20;k++)              
            {  
                double ran=rand();   
                t.x=b[j].x+cos(ran)*i;  
                t.y=b[j].y+sin(ran)*i;  
                if (0>t.x || t.x>X || 0>t.y || t.y>Y)  
                    continue;  
                t.dis=dis(t);  
                if (t.dis>b[j].dis) b[j]=t;  
            }  
    ans.dis=-1;  
    for (int i=1;i<=20;++i)if (ans.dis<b[i].dis) ans=b[i];         
}  
  
int main()  
{  
    int test;  
    scanf("%d",&test);  
    while (test--)  
    {  
        scanf("%d %d %d",&X,&Y,&n);  
        for (int i=1;i<=n;i++)  
             scanf("%lf %lf",&a[i].x,&a[i].y);  
        Solve();  
        printf("The safest point is (%.1f, %.1f).\n",ans.x,ans.y);  
    }  
    return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值