poj 1379 Run Away(模拟退火)

Run Away
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5123 Accepted: 1600

Description

One of the traps we will encounter in the Pyramid is located in the Large Room. A lot of small holes are drilled into the floor. They look completely harmless at the first sight. But when activated, they start to throw out very hot java, uh ... pardon, lava. Unfortunately, all known paths to the Center Room (where the Sarcophagus is) contain a trigger that activates the trap. The ACM were not able to avoid that. But they have carefully monitored the positions of all the holes. So it is important to find the place in the Large Room that has the maximal distance from all the holes. This place is the safest in the entire room and the archaeologist has to hide there.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing three integers X, Y, M separated by space. The numbers satisfy conditions: 1 <= X,Y <=10000, 1 <= M <= 1000. The numbers X and Yindicate the dimensions of the Large Room which has a rectangular shape. The number M stands for the number of holes. Then exactly M lines follow, each containing two integer numbers Ui and Vi (0 <= Ui <= X, 0 <= Vi <= Y) indicating the coordinates of one hole. There may be several holes at the same position.

Output

Print exactly one line for each test case. The line should contain the sentence "The safest point is (P, Q)." where P and Qare the coordinates of the point in the room that has the maximum distance from the nearest hole, rounded to the nearest number with exactly one digit after the decimal point (0.05 rounds up to 0.1).

Sample Input

3
1000 50 1
10 10
100 100 4
10 10
10 90
90 10
90 90
3000 3000 4
1200 85
63 2500
2700 2650 
2990 100

Sample Output

The safest point is (1000.0, 50.0).
The safest point is (50.0, 50.0).
The safest point is (1433.0, 1669.8).

Source


题意:求一个范围离所有点最近距离最大的点
题解:模拟退火....不会证明....

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<time.h>
#define eps 1e-8
#define all 18
#define luck 33
#define pi acos(-1.0)
struct point{
    double x,y;
}p[1005],pp[38],now,cc;
double best[38];
int n;
double MIN(double a,double b){ return a<b?a:b; }
double dis(struct point x,struct point y)
{
    return  sqrt((x.x-y.x)*(x.x-y.x)+(x.y-y.y)*(x.y-y.y));
}
double alldis(struct point c)
{
    double ans=9999999999.0;
    int i;
    for(i=0;i<n;i++) ans=MIN(ans,dis(c,p[i]));
    return ans;
}
struct point rang_point(int i)
{
    struct point temp;
    temp.x=(rand()%1000+1)/1000.0*cc.x;
    temp.y=(rand()%1000+1)/1000.0*cc.y;
    best[i]=alldis(temp);
    return temp;
};
int check(struct point temp)
{
    if(temp.x<-eps||temp.x>cc.x+eps) return 0;
    if(temp.y<-eps||temp.y>cc.y+eps) return 0;
    return 1;
}
int main()
{
    int i,j,t,id;
    double step,angle,tmd;
    struct point temp;

    //freopen("t.txt","r",stdin);
    srand((unsigned)time(NULL));
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%d",&cc.x,&cc.y,&n);
        for(i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        for(i=0;i<all;i++) pp[i]=rang_point(i);
        step=(cc.x>cc.y?cc.x:cc.y);
        while(step>1e-3)
        {
            for(i=0;i<all;i++)
            {
                now=pp[i];
                for(j=0;j<luck;j++)
                {
                    angle=(rand()%1000+1)/1000.0*2*pi;
                    temp.x=now.x+cos(angle)*step;
                    temp.y=now.y+sin(angle)*step;
                    if(!check(temp)) continue;
                    tmd=alldis(temp);
                    if(tmd>best[i])
                    {
                        best[i]=tmd;
                        pp[i]=temp;
                    }
                }
            }
            step=step*0.83;
        }
        for(i=id=tmd=0;i<all;i++)
        {
            if(best[i]>tmd)
            {
                tmd=best[i];
                id=i;
            }
        }
        printf("The safest point is (%.1lf, %.1lf).\n",pp[id].x,pp[id].y);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值