字符处理

/* 
 *copyright(c)2013,烟台大学计算机学院 
 *ALL right reserved. 
 *作者:王凯 
 *完成日期:2013年 12月 1日 
 *版本号:v1.0 
 *问题描述:
 *样例输入: 
 *样例输出: 
 *问题分析:
 */  
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int i,j,upper,lower,digit,space,other;
    char text[3][80];
    upper=lower=digit=space=other=0;
    for(i=0; i<3; i++)
    {
        cout<<"please input line"<<i+1<<endl;
        gets(text[i]);
        for(j=0; j<80&&text[i][j]!='\0'; j++)
        {
            if(text[i][j]>='A'&&text[i][j]<='Z')
                upper++;
            else if(text[i][j]>='a'&&text[i][j]<='z')
                lower++;
            else if(text[i][j]>='0'&&text[i][j]<='9')
                digit++;
            else if (text[i][j]==' ')
                space++;
            else
                other++;
        }
    }
    cout << "upper case:"<<upper << endl;
    cout << "lower case:"<<lower << endl;
    cout << "digit:"<<digit << endl;
    cout << "space:"<<space << endl;
    cout << "other:"<<other<< endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值