/*
*Copyright (c) 2013 ,烟台大学计算机与控制工程学院
*All rights reserved.
*作者:王至超
*完成日期:2014年05月25
*版本号:v1.0
*问题描述:
*样例输入:
*样例输出:
*问题分析:用简单的方法,学会活学活用
*/
#include <iostream>
using namespace std;
class Rectangle //矩形类
{
private:
int length; //矩形的长和宽
int width;
public:
Rectangle();
Rectangle(int l,int w); //构造函数,l、w分别代表长和宽
int getArea(); //求面积
};
class Bulk: public Rectangle //立方体类
{
public:
Bulk(); //默认构造函数
Bulk(int l, int w,int h); //带参数的构造函数
int getVolume();
private:
int height; //高,长、宽继承自基类
};
//只提交begin到end部分的代码
//*********** begin *************
//Rectangle类的成员函数
Rectangle::Rectangle():length(0),width(0){}
Rectangle::Rectangle(int l,int w)
{
length=l;
width=w;
}
int Rectangle::getArea()
{ double c;
c=length*width;
return c;
}
//Bulk类的成员函数
Bulk::Bulk():Rectangle(),height(0){}
Bulk::Bulk(int l, int w,int h):Rectangle(l,w),height(h){}
int Bulk::getVolume()
{
double n;
n=getArea();
return n*height;
};
//*********** end ***************
int main()
{
int x,y,z;
cin>>x>>y>>z;
Bulk b(x,y,z);
cout<<b.getVolume()<<endl;
return 0;
}
体积
最新推荐文章于 2024-03-17 15:30:01 发布