poj——3894 迷宫问题

水题,简单的BFS,不过也有很多人用DFS做,题意我就不说了,本身很明白!

用一个一维数组把搜到的点记下来,根据他们的父节点倒着输出来!

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8990 Accepted: 5317

Description

定义一个二维数组:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 110

int fx[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
int father[maxn][maxn];
int visit[maxn][maxn];
int map1[maxn][maxn];
int dist[maxn][maxn];
int short1[maxn];
int sx=0,sy=0;
int ex=4,ey=4;
int n=5;

void pt()
{
    int x=ex,y=ey;
    int j=0;
    for(;;)
    {
        short1[j++]=father[x][y];
        int fx=father[x][y]/n;
        int fy=father[x][y]%n;
        if(fx==sx&&fx==sy)
        {
            break;
        }
        x=fx;
        y=fy;
    }
    int px,py;
    while(j--)
    {
        px=short1[j]/n;
        py=short1[j]%n;
        printf("(%d, %d)\n",px,py);
    }
    printf("(%d, %d)\n",ex,ey);
}

void bfs(int x,int y)
{
    int u,v,nx,ny;
    u=x*n+y;
    queue<int> s;
    s.push(u);
    father[x][y]=-1;
    visit[x][y]=1;
    dist[x][y]=0;
    while(!s.empty())
    {
        u=s.front();
        s.pop();
        x=u/n;
        y=u%n;
        for(int i=0;i<4;i++)
        {
            nx=x+fx[i][0];
            ny=y+fx[i][1];
            if(!visit[nx][ny]&&nx>=0&&nx<5&&ny>=0&&ny<5&&map1[nx][ny]==0)
            {
                visit[nx][ny]=1;
                dist[nx][ny]=dist[x][y]+1;
                father[nx][ny]=u;
                v=nx*n+ny;
                s.push(v);
                if(nx==ex&&ny==ey)
                {
                    pt();
                }
            }
        }
    }
}
int main()
{
    int i,j;
    for(i=0;i<5;i++)
        for(j=0;j<5;j++)
        scanf("%d",&map1[i][j]);
    bfs(0,0);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值