POJ 3894 System Engineer 二分图匹配 Hopcroft_Carp 最大流

 
System Engineer
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 236 Accepted: 98

Description

Bob is a skilled system engineer. He is always facing challenging problems, and now he must solve a new one. He has to handle a set of servers with differing capabilities available to process job requests from persistent sources - jobs that need to be processed over a long or indefinite period of time. A sequence of persistent job requests arrives revealing a subset of servers capable of servicing their request. A job is processed on a single server and a server processes only one job. Bob has to schedule the maximum number of jobs on the servers. For example, if there are 2 jobs j1, j2 and 2 servers s1, s2, job j1 requiring the server s1, and job j2 requiring also the server s1. In this case Bob can schedule only one job. Can you help him?
In the general case there are n jobs numbered from 0 to n-1, n servers numbered from n to 2*n-1, and a sequence of job requests. The problem asks to find the maximum number of jobs that can be processed.

Input

The program input is at most 1 MB. Each data set in the file stands for a particular set of jobs. A data set starts with the number n (n <= 10000) of jobs, followed by the list of required servers for each job, in the format: jobnumber: (nr_servers) s1 ... snr_servers The program prints the maximum number of jobs that can be processed.
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

2 
0: (1) 2 
1: (1) 2 
1 
0: (1) 1

Sample Output

1
1

Hint

There are two data sets. In the first case, the number of jobs n is 2, numbered 0 and 1. The sequence of requests for job 0 is: 0: (1) 2, meaning that job 0 requires 1 sever, the server numbered 2. The sequence of requests for job 1 is: 1: (1) 2, meaning that job 1 requires 1 sever, the server numbered 2. The result for the data set is the length of the maximum number of scheduled jobs, 1.

Source

 
 
二分图匹配。
n最大10000,m未知。
使用普通的匈牙利算法应该会超时。

Hopcroft_Carp算法时间复杂度是O(n^0.5*m)。

用Dinic算法求最大流比匹配更快。

 

Hopcroft_Carp代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

const int N=10005;
const int INF=1<<28;
int Mx[N],My[N],Nx,Ny;
int dx[N],dy[N],dis;
vector<int> adj[N];
bool vst[N];
bool searchP()
{
    queue<int> q;
    dis=INF;
    memset(dx,-1,sizeof(dx));
    memset(dy,-1,sizeof(dy));
    for(int i=0;i<Nx;i++)
        if(Mx[i]==-1)
        {
            q.push(i);
            dx[i]=0;
        }
    while(!q.empty())
    {
        int u=q.front(),v;
        q.pop();
        if(dx[u]>dis)
			break;
		for(int i=0;i<adj[u].size();i++)
            if(dy[v=adj[u][i]]==-1)
            {
                dy[v]=dx[u]+1;
                if(My[v]==-1)
					dis = dy[v];
                else
                {
                    dx[My[v]]=dy[v]+1;
                    q.push(My[v]);
                }
            }
    }
    return dis!=INF;
}
bool dfs(int u)
{
	int i,v;
	for(i=0;i<adj[u].size();i++)
        if(!vst[v=adj[u][i]]&&dy[v]==dx[u]+1)
        {
            vst[v]=1;
            if(My[v]!=-1&&dy[v]==dis)
				continue;
            if(My[v]==-1||dfs(My[v]))
            {
                My[v]=u;
                Mx[u]=v;
                return 1;
            }
        }
    return 0;
}
int MaxMatch()//O(n^0.5*m)
{
    int ans=0;
    memset(Mx,-1,sizeof(Mx));
    memset(My,-1,sizeof(My));
    while(searchP())
    {
        memset(vst,0,sizeof(vst));
        for(int i=0;i<Nx;i++)
            if(Mx[i]==-1&&dfs(i))
				ans++;
    }
    return ans;
}
int main()
{
	int n,m,i,j,k;
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
		{
			scanf("%d: (%d)",&j,&m);
			adj[j].clear();
			while(m--)
			{
				scanf("%d",&k);
				adj[j].push_back(k-n);
			}
		}
		Nx=Ny=n;
		printf("%d\n",MaxMatch());
	}
}


 Dinic代码:

#include<cstdio>
#include<cstring>
#define N 20005
#define M 200005
#define inf 999999999
#define min(a,b) ((a)<(b)?(a):(b))

int n,m,s,t,num,adj[N],dis[N],q[N];
struct edge
{
	int v,w,pre;
}e[M];
void insert(int u,int v,int w)
{
	e[num]=(edge){v,w,adj[u]};
	adj[u]=num++;
	e[num]=(edge){u,0,adj[v]};//有向图
	adj[v]=num++;
}
int bfs()
{
	int i,x,v,head=0,tail=0;
	memset(dis,0,sizeof(dis));
	dis[s]=1;
	q[++tail]=s;
	while(head!=tail)
	{
		x=q[head=(head+1)%N];
		for(i=adj[x];~i;i=e[i].pre)
			if(e[i].w&&!dis[v=e[i].v])
			{
				dis[v]=dis[x]+1;
				if(v==t)
					return 1;
				q[tail=(tail+1)%N]=v;
			}
	}
	return 0;
}
int dfs(int x,int limit)
{
	if(x==t)
		return limit;
	int i,v,tmp,cost=0;
	for(i=adj[x];~i&&cost<limit;i=e[i].pre)
		if(e[i].w&&dis[x]==dis[v=e[i].v]-1)
		{
			tmp=dfs(v,min(limit-cost,e[i].w));
			if(tmp)
			{
				e[i].w-=tmp;
				e[i^1].w+=tmp;
				cost+=tmp;
			}
			else
				dis[v]=-1;
		}
	return cost;
}
int Dinic()
{
	int ans=0;
	while(bfs())
		ans+=dfs(s,inf);
	return ans;
}
int main()
{
	while(~scanf("%d",&n))
	{
		int i,j,k;
		memset(adj,-1,sizeof(adj));
		num=0;
		s=0;
		t=n+n+1;
		for(i=0;i<n;i++)
		{
			scanf("%d: (%d)",&j,&m);
			while(m--)
			{
				scanf("%d",&k);
				insert(j+1,k+1,1);
			}
		}
		for(i=1;i<=n;i++)
		{
			insert(s,i,1);
			insert(i+n,t,1);
		}
		printf("%d\n",Dinic());
	}
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值