杭电hdu_2035_人见人爱A^B

Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 


Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 


Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 


Sample Input
2 3
12 6
6789 10000
0 0
 


Sample Output
8
984
1
 #include<memory>
#include<iostream>
#include<string>
//#include<QPainter>
//#include<fstream>
#include<cctype>
#include<algorithm>
#include<cmath>
#include<map>
using namespace std;
void cost_time()
{
    cout<<"调用该程序所花费的时间为:"<<clock()/CLOCKS_PER_SEC<<"秒\n";
    cout<<"调用该程序所花费的时间为:"<<clock()<<"毫秒\n";
}
int effect_three(int  a,int  b)
{
    int ans = 1;
    for (int var = 0; var < b; ++var) {
        ans = ans*a % 1000;
    }
    return ans;
}
int main(int argc, char *argv[])
{


    int a,b;
    map<int,int> mapvec;
    pair<int,int> pairvec;
    map<int,int>::iterator itermap;
    while(cin >> a >> b)
    {
        if(!a && !b) break;




        int i = effect_three (a,b);
        cout <<  i << endl;


    }




    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值