2014ACM/ICPC广州赛区I题(dfs+剪枝)(hdu5135)

Little ZuChongzhi's Triangles

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 512000/512000 K(Java/Others)
Total Submission(s): 219    Accepted Submission(s): 118


Problem Description

Zu Chongzhi(429–500) was a prominent Chinese mathematician and astronomer during the LiuSong and Southern Qi Dynasties. Zu calculated the value ofπ to the precision ofsix decimal places and for a thousand years thereafter no subsequentmathematician computed a value this precise. Zu calculated one year as365.24281481 days, which is very close to 365.24219878 days as we know today.He also worked on deducing the formula for the volume of a sphere. 

It is said in some legend story books that when Zu was a little boy, he likedmathematical games. One day, his father gave him some wood sticks as toys. ZuChongzhi found a interesting problem using them. He wanted to make sometriangles by those sticks, and he wanted the total area of all triangles hemade to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.
2) A triangle's vertexes must be end points of sticks. A triangle's vertexcouldn't be in the middle of a stick.
3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problemrather than a mathematical problem. You can't solve that problem without acomputer if there are too many sticks. So please bring your computer and goback to Zu's time to help him so that maybe you can change the history.

 

 

Input

There are no morethan 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number ofsticks Zu Chongzhi had got. The second line contains N integers, meaning thelength of N sticks. The length of a stick is no more than 100. The input endswith N = 0.

 

 

Output

For each testcase, output the maximum total area of triangles Zu could make. Round theresult to 2 digits after decimal point. If Zu couldn't make any triangle, print0.00 .

 

 

Sample Input

3

1 1 20

7

3 4 5 3 4 5 90

0

 

Sample Output

0.00

13.64

题目理解主要就是那三个条件:三根木棍组成三角形、首尾相连、可以不用所有的木棍。

其实就是在用一堆木棍去组成三角形,求这些三角形的最大面积和。


思路:

枚举所有能组成的三角形,dfs所搜这些三角形并求出最大面积。

n最大为12,用dfs复杂度为(12*11*10)*(9*8*7)*(6*5*4)*(3*2*1)=12!=479001600,差不多是5*10^8;

应该会超时,所以加了剪枝:

当前的三角形面积加上尽可能多大的面积都比已求出的最大面积小就没有必要搜索下去。

尽可能大的面积:当剩下的木棍的长度和去组成面积最大的图形,显然园形的面积最大。

if(ans>=nowsum+sp*sp/(4.0*3.141592653))  return ;


在杭电上重挂的时候测试93ms;

把剪枝去掉156ms !! 不知道是不是数据不完整。。。。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<cmath>
#define INF 0xfffffff
#define MAX 1000000
#define CLR(a,b) memset((a),(b),sizeof((a)))
using namespace std;
int n;
double ans;//最大面积
int w[15];
bool vis[15];
double hf(int a, int b, int c)//海伦公式求三角形的面积
{
    double p = (a+b+c)*0.5;
    return sqrt(p*(p-a)*(p-b)*(p-c));
}
void dfs(double nowsum,int x,double sp) //当前面积,已使用的根数。剩余长度和
{
    ans=max(ans,nowsum);
    if(x+3>n) return ;//使用超过n根跳出
    if(ans>=nowsum+sp*sp/(4.0*3.141592653))//剪枝:当前面积加上剩余的面积都比最大面积小
        return ;                          //不需要搜索直接跳出
    for(int i=0; i<n; i++)
        if(!vis[i])
            for(int j=i+1; j<n; j++)
                if(!vis[j])
                    for(int k=j+1; k<n; k++)
                        if(!vis[k])
                        {
                            if(w[i]+w[j]>w[k]&&w[i]+w[k]>w[j]&&w[j]+w[k]>w[i])//满足构成三角形
                            {
                                double tmp=sp-w[i]-w[j]-w[k];
                                vis[i]=vis[j]=vis[k]=true;//标记已使用
                                dfs(nowsum+hf(w[i],w[j],w[k]),x+3,tmp);
                                vis[i]=vis[j]=vis[k]=false;
                            }
                        }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        double sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&w[i]);
            sum+=w[i];
        }
        ans=0;
        dfs(0,0,sum);
        printf("%.2f\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值