HOJ Train Problem II

题目链接

Train Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7186 Accepted Submission(s): 3876

Problem Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input

1
2
3
10

Sample Output

1
2
5
16796

Hint

The result will be very large, so you may not process it by 32-bit integers.

用到了组合数学,Cantalan数
Catalan数
Catalan数总结

代码:

#include <iostream>
const int MAX = 100 + 10;
const int LEN = MAX - 1;
using namespace std;
int Cat[MAX][MAX];

int initial()
{
    int i,j,k;
    int temp;
    int digit;
    int carry;
    int multi;
    int t;

    Cat[0][0] = 1;
    Cat[0][LEN] = 1;
    for(i = 1; i < MAX; i++)
    {
        t = i - 1;
        multi = 4 * t + 2;
        carry = 0;
        digit = Cat[i - 1][LEN];
        for(j = 0; j < digit; j++)
        {
            temp = Cat[i - 1][j] * multi + carry;
            Cat[i][j] = temp % 10;
            carry = temp / 10;
        }
        while(carry)
        {
            Cat[i][digit++] = carry % 10;
            carry /= 10;
        }
        t = (i - 1) + 2;
        for(j = digit - 1; j >= 0; j--)
        {
            temp = carry * 10 + Cat[i][j];
            Cat[i][j] = temp / t;
            carry = temp % t;
        }
        while(!Cat[i][digit - 1])
            digit--;
        Cat[i][LEN] = digit;
    }


    return 0;
}
void print(int k)
{
        for(int j = Cat[k][LEN] - 1; j >= 0; j--)
            cout << Cat[k][j];
            cout << endl;
}
int main()
{
    int n;
    initial();

    while(cin >> n)
        print(n);

    return 0;
}

总结:注意递推式的下标,最好用一个数字代替;注意大数相乘之后的除法,中途除会产生错误;注意输出格式,末尾0 的清除。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值