http://acm.hdu.edu.cn/showproblem.php?pid=1175
连连看
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16171 Accepted Submission(s): 4172
Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
注意:询问之间无先后关系,都是针对当前状态的!
Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
Sample Input
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
Sample Output
YES NO NO NO NO YES
做完才发现 竟然是一道bfs的题.......
搜索都忘记怎么写了...
WA了很多次。。。
郁闷ing..................
差一点就超时了...
//hdu 1175 连连看
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define ll long long
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn=1005;
int n,m;
int g[maxn][maxn];
bool vis[maxn][maxn];
int q;
int x1,y1,x2,y2;
int fx[5]={0,0,1,-1, 0,};
int fy[5]={0,1,0, 0,-1,};
struct p
{
int x;int y;int r;int d;//d=1,2,3,4 右下上左
};
void solve()
{
if(g[x1][y1]==0||g[x2][y2]==0||g[x1][y1]!=g[x2][y2]) {puts("NO");return; }
stack <p> st;
p now,next;
now.x=x1,now.y=y1,now.r=0,now.d=0;
st.push(now);
int ok=0;
while(!st.empty())
{
now=st.top();
st.pop();
vis[now.x][now.y]=true;
if(now.x==x2&&now.y==y2) {ok=1;break;}
for(int i=1;i<=4;i++)
{
if(now.d+i==5) continue;
next.x=now.x+fx[i];
next.y=now.y+fy[i];
next.d=i;
if(next.d!=now.d)
next.r=now.r+1;
else next.r=now.r;
//cout<<next.x<<' '<<next.y<<' '<<next.d<<' '<<next.r<<endl;
if( (g[next.x][next.y]==0&&vis[next.x][next.y]==false&&next.r<=3)||(next.x==x2&&next.y==y2&&next.r<=3))//因为这里wa了很久
{
st.push(next);//cout<<"in"<<endl;
}
}
vis[now.x][now.y]=false; //去除标记是必须的
}
if(ok) puts("YES");
else puts("NO");
}
int main()
{
//freopen("input.txt","r",stdin);
while(cin>>n>>m,n)
{
memset(vis,false,sizeof(vis));
memset(g,0x3f,sizeof(g));
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&g[i][j]);
cin>>q;
while(q--)
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
solve();
}
}
return 0;
}