学生围成圈分糖果问题(Problem ID:1034)

题址:http://acm.hdu.edu.cn/showproblem.php?pid=1034

Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.


Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.


Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.


Sample Input
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0


Sample Output
15 14
17 22
4 8

Hint

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.


简单题,模拟一圈的情况。

先用temp存放最后一个的一半糖果temp=round[n-1]/2,然后接下来就是一圈循环做了,round[i]=round[i]/2+temp,表示上一个人的一半糖果加上自己剩下的一半糖果成为这圈过后自己手中最后的糖果数,由题意,此时若为奇数则问老师拿一个糖果补成偶数,偶数就直接ok了。

循环数number,循环一圈number就+1,知道出现所有人的round[i]都相等时循环中断,输出结果。


AC代码:

#include<stdio.h>
int main()
{
	int n;
	int i,round[100],number,temp,t;
	while(scanf("%d",&n)!=EOF && n!=0)
	{
		for(i=0;i<n;i++)	
			scanf("%d",&round[i]);
		for(number=1; ;number++)
		{
			temp=round[n-1]/2;
			for(i=0;i<n;i++)
			{
				t=round[i]/2;
				round[i]=round[i]/2+temp;
				temp=t;
			}
			//for(i=0;i<n;i++)
			//	printf("%d\n",round[i]);
			for(i=0;i<n;i++)
			{
				if(round[i]%2==1)
					round[i]+=1;
			}
			for(i=0;i<n;i++)
				if(round[i]!=round[i+1])
					break;
			//printf("%d\n",i);
			if(i==(n-1))
			{
				printf("%d %d\n",number,round[0]);	break;
			}
			else
				continue;
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值