杭电OJ Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35606    Accepted Submission(s): 19443


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
 

Author
ZHENG, Jianqiang
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1005  1004  1009  1021  1003 
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                题意:我们城市最高的建筑只有一个电梯。电梯的命令是由N个数字组成。这些数字表示在这楼层电梯将停止,这些数字是顺序是确定的。它每上一层要6秒,每下一层要4秒,电梯没停一次的时间是5秒。对于一个给定的输入,计算出总时间。电梯在第0层开始,....

题解:用数组b[100]存放所要停顿的楼层,n[1000]存放时间。先计算每次电梯停顿的时间,再计算在上下楼时所花费的时间。....
最后输出总时间便是。

#include<iostream>
using namespace std;
int n[1000]={};
int b[100];
int main()
{
	int N,i,j=0;
	cin>>N;
	while(N!=0){
		for(i=0;i<N;i++){
		cin>>b[i];	
		}
		n[j]+=N*5+b[0]*6;
		for(i=0;i<N-1;i++)
		{
			if(b[i]<b[i+1])
			n[j]+=(b[i+1]-b[i])*6;
		   else
		    n[j]+=(b[i]-b[i+1])*4;
		   }
		   j++;  cin>>N;
	}
	for(i=0;n[i]!=0;i++)
	cout<<n[i]<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值