迷宫问题-广度优先搜索

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?


Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.


Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s). 

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line 

Trapped!


Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0


Sample Output

Escaped in 11 minute(s).

Trapped!


题解:最初我试了一下动态规划,结果失败,为什么呢?因为动态规划先做什么后做什么必须明确,而迷宫问题却不知道先算谁后算谁.还是广度优先快.

实现队列非常简单,一定要手动背写下来.

#include<iostream>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<time.h>
#include<stdlib.h>
using namespace std; 
int a[31][31][31];
char map[31][31][31];
int xsize, ysize, zsize;
struct Point{
	int x, y, z;
};
struct queue{
	Point a[10000];
	int head, rear;
	void init(){
		head = rear = 0;
	}
	void enq(int x,int y ,int z){
		Point&p = a[rear];
		p.x = x;
		p.y = y;
		p.z = z;
		rear++;
		rear %= 10000;
	}
	Point& deq(){
		int temp = head;
		head++;
		head %= 10000;
		return a[temp];
	}
	bool isEmpty(){
		return rear == head;
	}
};
queue q;
int sx, sy, sz;
int ans=-1;
void check(int x, int y, int z,int father){
	if (x < 0 || y < 0 || z < 0)return;
	if (x >= xsize || y >= ysize || z >= zsize)return;
	if (~a[x][y][z])return;
	if (map[x][y][z] == '#')return;
	if (map[x][y][z] == 'E'){
		ans = father + 1;
		return;
	}
	a[x][y][z] = father + 1;
	q.enq(x, y, z);
}
void go(){
	memset(a, -1, sizeof(a));
	ans = -1;
	q.init();
	q.enq(sx, sy, sz);
	a[sx][sy][sz] = 0;
	while (!q.isEmpty()){
		Point &p = q.deq();
		int&x = p.x;
		int &y = p.y;
		int &z = p.z; 
		int &f = a[x][y][z];
		check(x + 1, y, z,f);
		check(x - 1, y, z,f);
		check(x, y + 1, z,f);
		check(x, y - 1, z,f);
		check(x, y, z + 1,f);
		check(x, y, z - 1,f);
		if (~ans)return;
	}
}
int main(){ 
	while (cin >> xsize >> ysize >> zsize && (xsize || ysize || zsize)){
		int i, j, k; 
		for (i = 0; i < xsize; i++){
			for (j = 0; j < ysize; j++){
				for (k = 0; k < zsize; k++){
					cin >> map[i][j][k];
					if (map[i][j][k] == 'S'){
						sx = i;
						sy = j;
						sz = k;
						a[i][j][k] = -1;
					} 
				}
			}
		} 
		go();
		if (ans==-1 ) cout << "Trapped!" << endl;
		else cout << "Escaped in " << ans << " minute(s)." << endl;
	}
	return 0;
}


广度优先搜索(BFS)常用于解决迷宫问题。下面是一个简单的迷宫问题的C语言实现: ```c #include<stdio.h> #include<stdlib.h> #define ROW 5 #define COL 5 struct Node{ int x; int y; int step; int prev; }; int bfs(int maze[ROW][COL], int start_x, int start_y, int end_x, int end_y){ int dx[4] = {0, 0, 1, -1}; int dy[4] = {1, -1, 0, 0}; int visited[ROW][COL] = {0}; struct Node queue[ROW * COL]; int head = 0, tail = 0; queue[tail].x = start_x; queue[tail].y = start_y; queue[tail].step = 0; queue[tail].prev = -1; tail++; visited[start_x][start_y] = 1; while(head < tail){ struct Node cur = queue[head]; head++; if(cur.x == end_x && cur.y == end_y){ printf("The shortest path is %d.\n", cur.step); int prev = cur.prev; while(prev != -1){ printf("(%d, %d) <- ", queue[prev].x, queue[prev].y); prev = queue[prev].prev; } printf("(%d, %d)\n", cur.x, cur.y); return cur.step; } for(int i = 0; i < 4; i++){ int next_x = cur.x + dx[i]; int next_y = cur.y + dy[i]; if(next_x >= 0 && next_x < ROW && next_y >= 0 && next_y < COL && maze[next_x][next_y] == 0 && visited[next_x][next_y] == 0){ visited[next_x][next_y] = 1; queue[tail].x = next_x; queue[tail].y = next_y; queue[tail].step = cur.step + 1; queue[tail].prev = head - 1; tail++; } } } printf("There is no path from (%d, %d) to (%d, %d).\n", start_x, start_y, end_x, end_y); return -1; } int main(){ int maze[ROW][COL] = { {0, 0, 0, 0, 0}, {0, 1, 0, 1, 0}, {0, 0, 0, 0, 0}, {0, 1, 0, 1, 0}, {0, 0, 0, 0, 0} }; bfs(maze, 0, 0, 4, 4); return 0; } ``` 在这个例子中,我们使用了一个结构体`Node`来表示迷宫中的一个节点,其中`x`和`y`表示节点的坐标,`step`表示从起点到当前节点的步数,`prev`表示当前节点的前一个节点在队列中的下标。 在`bfs`函数中,我们使用了一个队列来进行广度优先搜索。首先将起点加入队列中,并标记为已经访问过。然后不断从队列头部取出节点,对其四个相邻节点进行判断,如果满足条件则加入队列,并标记为已经访问过。重复以上过程,直到队列为空或者找到终点。 当找到终点时,我们可以根据节点的`prev`属性回溯到起点,输出最短路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值