Description
Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.
They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.
Output
For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where Mis as small as possible.
Sample Input
3
10
5
12
Sample Output
Case 1: 5 2
Case 2: Impossible
Case 3: 3 4
题意: 输入一个数, 判断是否能否分解成 一个奇数和一个偶数的乘积 ,若能输出一组符合条件的奇数和偶数 ,若不能,输出 Impossible
#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
int n,T;
long long num;
int main()
{
scanf("%d",&T);
for(int co=1;co<=T;co++)
{
scanf("%lld",&num);
long long ret=1;
while(num%2==0)
{
num/=2;
ret*=2;
}
if(ret==1) printf("Case %d: Impossible\n",co);
else printf("Case %d: %lld %lld\n",co,num,ret);
}
return 0;
}