hdu 4786 Fibonacci Tree ( 最小生成树 )

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2487    Accepted Submission(s): 796


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 



题意 :  给你一张无向图,其中有的边为白色,有的边为黑色,问你是否有一颗生
成树并且它的白色边是斐波那契数列中的一个数。
思路 : 因为边为白色的权值为1,黑色的权值为0。即在原图的基础上分别求一
遍最小生成树和一遍最大生成树。假设求出的最小生成树的总权值为 Min ,最大
生成树的总权值为 Max , 那么我们可知生成树中最小的白边数为 Min ,最大白
边数为 Max。然后我们只要判断这两个值之间是否存在斐波那契数就行了。
上述结论其实是要证明对于所有在Min和Max之间的白边数都可以。
原因 :在最大生成树上去掉Max - Min 条白边,可知最大生成树会变成
Max - Min+1 个连通块,并且这些连通块中已经有 Min条白边 ,所以可知这
 Max - Min+1个连通块 可以通过 Max - Min 条黑边连接起来 。 将这 Max - Min+1
个连通块看做成 Max - Min+1个点,即这些点可以全通过白边或黑边连接起来。
那么可以得出这些点也可以通过n条白边和m条黑边连接起来 (m+n = Max - Min)。

即可行的白边数为 ans = Min+n , 因为 0 <= n <=Max-Min ,所以 Min <= ans <=Max 。 


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=100010;
const int N=30;

struct edge
{
    int u,v,val;
} a[maxn];
int id[maxn],f[N]= {0,1,2},n,m,T;

bool cmp1(edge p,edge q)
{
    return p.val<q.val;
}

bool cmp2(edge p,edge q)
{
    return p.val>q.val;
}

int Find(int x)
{
    if(x!=id[x]) id[x]=Find(id[x]);
    return id[x];
}

void input()
{
    scanf("%d %d",&n,&m);
    for(int i=0; i<m; i++) scanf("%d %d %d",&a[i].u,&a[i].v,&a[i].val);
}

int kru()
{
    for(int i=0; i<maxn; i++)  id[i]=i;
    int res=0,num=0;
    for(int i=0; i<m; i++)
    {
        int p=Find(a[i].u),q=Find(a[i].v);
        if(p!=q)
        {
            id[p]=q;
            res+=a[i].val;
        }
    }
    for(int i=1; i<=n; i++)  if(Find(i)==i)  num++;
    if(num>1)  return -1;
    return res;
}

void solve(int co)
{
    int l,r;
    sort(a,a+m,cmp1);
    l=kru();
    sort(a,a+m,cmp2);
    r=kru();
    if(l==-1 || r==-1)
    {
        printf("Case #%d: No\n",co);
        return ;
    }
    else
    {
        for(int i=1; i<N; i++)
        {
            if(f[i]>=l && f[i]<=r)
            {
                printf("Case #%d: Yes\n",co);
                return ;
            }
        }
        printf("Case #%d: No\n",co);
    }
}

int main()
{
    for(int i=3; i<N; i++)  f[i]=f[i-1]+f[i-2];
    scanf("%d",&T);
    for(int co=1; co<=T; co++)
    {
        input();
        solve(co);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值