hdu 4786 Fibonacci Tree(最小生成树)

68 篇文章 0 订阅
10 篇文章 0 订阅

Fibonacci Tree

Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, … )

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 105) and M(0 <= M <= 105).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.

Sample Input
2
4 4
1 2 1
2 3 1
3 4 1
1 4 0
5 6
1 2 1
1 3 1
1 4 1
1 5 1
3 5 1
4 2 1

Sample Output
Case #1: Yes
Case #2: No

分析:
生成的最小生成树和最大生成树他们之间不同的边肯定是那些可以替换的边,也就是说他们之间的每一种树都可以生成,所以直接判断他们之间是否有斐波那契数就可以了

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 100010
struct edge
{
    int u,v,w;
} e[maxn];
int pre[maxn],vis[maxn],a[maxn];
int n,m;

bool cmp1(edge a,edge b)
{
    return a.w<b.w;
}

bool cmp2(edge a,edge b)
{
    return a.w>b.w;
}

void Fibonacci()
{
    a[1]=1,a[2]=2;
    for(int i=3; a[i-1]<=100000; ++i)
        a[i]=a[i-1]+a[i-2],vis[a[i]]=1;
}

void init()
{
    for(int i=1; i<=n; ++i)
        pre[i]=i;
}

int Find(int x)
{
    if(x==pre[x])
        return x;
    pre[x]=Find(pre[x]);
    return pre[x];
}

int join(int x,int y)
{
    int fx=Find(x),fy=Find(y);
    if(fx!=fy)
    {
        pre[fy]=fx;
        return 1;
    }
    return 0;
}

int Kruskal_min()
{
    init();
    sort(e,e+m,cmp1);
    int cont=0,sum=0;
    for(int i=0; i<m; ++i)
    {
        if(join(e[i].u,e[i].v))
        {
            cont++;
            sum+=e[i].w;
        }
        if(cont==n-1)
            break;
    }
    if(cont<n-1)
        return -1;
    return sum;
}

int Kruskal_max()
{
    init();
    sort(e,e+m,cmp2);
    int cont=0,sum=0;
    for(int i=0; i<m; ++i)
    {
        if(join(e[i].u,e[i].v))
        {
            cont++;
            sum+=e[i].w;
        }
        if(cont==n-1)
            break;
    }
    if(cont<n-1)
        return -1;
    return sum;
}

int main()
{
    Fibonacci();
    int t,k=0;
    scanf("%d",&t);
    while(++k<=t)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; ++i)
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
        int s1=Kruskal_min();
        int s2=Kruskal_max();
        if(s1==-1||s2==-1)
            printf("Case #%d: No\n",k);
        else
        {
            int flag=0;
            for(int i=s1; i<=s2; ++i)
                if(vis[i])
                {
                    flag=1;
                    break;
                }
            if(flag)
                printf("Case #%d: Yes\n",k);
            else
                printf("Case #%d: No\n",k);
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值