A Funny Game
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 3843 | Accepted: 2298 |
Description
Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10
6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)
Figure 1
Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)
Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
Figure 1
Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)
Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, if Alice win the game,output "Alice", otherwise output "Bob".
Sample Input
1 2 3 0
Sample Output
Alice Alice Bob
思路:
n > 3 时,先手必败。题目很简单,而关键在于思想;
对称博弈的典型题目:
当n > 3 时,无论A怎么选择,B可以选一个特殊的位置拿走1个连续的2个,将A取剩的环路剪成两条相同的链路,然后,无论A从那条链路中那个位置取几个,B都可以在另一条链路中采用相同的取法。此时,B慢A一步,即最后一个一定是B取到的,B必胜!
代码:
#include <stdio.h>
int main()
{
int n;
while(scanf("%d", &n), n){
if(n <= 2)
printf("Alice\n");
else
printf("Bob\n");
}
return 0;
}