Phone List

Phone List

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

输入
The first line of input gives a single integer, 1 ≤ t ≤ 10, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 100000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
输出
For each test case, output "YES" if the list is consistent, or "NO" otherwise.
样例输入
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
样例输出
NO
YES

思路:字典树(前缀树)的简单应用。

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct Node                        //字典树节点
{
	//	char word[11];
	int flag;
	Node *next[10];
}node;

int insert(node *tree, char str[])
{
	node *p = tree, *t;
	char *s = str;
	int cnt, i;
	while(*s)
	{	
		cnt = *s - '0';
		if(p->next[cnt] == NULL)
		{
			t = (node *)malloc(sizeof(node));
			for(i = 0; i < 10; i++)
			{
				t->next[i] = NULL;
			}
			if(*(s+1) == 0)                  //在最后一个节点插入标记
			{
				t->flag = 1;
			}
			else
			{
				t->flag = 0;
			}
			p->next[cnt] = t;
		}
		else
		{
			if(*(s+1) == 0)                   //两种情况判断前缀, 一种是到str结束也没新建节点(节点已存在),另一种是中途遇到其他str的结束标志 
			{
				return 0;
			}
			if((p->next[cnt])->flag)
			{
				return 0;
			}
		}
		s++;
		p = p->next[cnt];
	}
	//	strcpy(t->word, str);
	return 1;
}

int main()
{
	int n, m, i, flag;
	node tree;
	char str[11];
	scanf("%d", &n);
	while(n--)
	{
		for(i = 0; i < 10; i++)                  //初始化
		{
			tree.next[i] = NULL;
		}
		flag = 1;
		scanf("%d", &m);
		for(i = 0; i < m; i++)
		{
			scanf("%s", str);
			if(flag)                              //若已经发现前缀树就不必继续添加了
			{
				if(!insert(&tree, str))
				{
					flag = 0;
				}
			}
		}
		if(flag)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值