Largest Rectangle in a Histogram

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000

思路:

单调队列的应用(虽然经优化的暴搜也能过), 说是队列但是用的是一个栈, 每次

遇到比栈顶大的, 就直接进栈, 若遇到比栈顶小的就向外弹栈, 并更新结果(最大

面积), 使栈始终“单调”。

#include <stdio.h>
#include <stdlib.h>

#define max(a,b) a>b?a:b                                   //比较函数

int stack[100005], wide[100005], top;

int main()
{
	int n, i, hight, len;
	long long ans;
	while(scanf("%d", &n) && n != 0)
	{
		top = -1;                                               //初始化栈顶
		ans = 0;
		for(i = 0; i <= n; i++)
		{
			if(i < n)
			{
				scanf("%d", &hight);
			}
			else
			{
				hight = -1;                                      //最后设为-1,以便把 i = n-1 放入比较
			}
			if(top == -1 || hight > stack[top])                   //单调递增直接入栈
			{
				stack[++top] = hight;
				wide[top] = 1;
			}
			else
			{
				len = 0;   
				while(hight <= stack[top] && top >= 0)
				{
					ans = max(ans, (long long)(wide[top]+len) * stack[top]);         //更新ans(注意此处longlong放在外面)
					len += wide[top--];                                              //向前更新len(比hight高的矩形)
				}
				if(hight > 0)                                                        //将hight放入, wide设为比hight高的总宽
				{
					stack[++top] = hight;
					wide[top] = len+1;
				}
			}
		}
		printf("%lld\n", ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值